<!doctype html>
<html lang="en">
<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="theme-color" content="#75411c" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">

<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script>
<link rel="preconnect" href="https://fonts.gstatic.com">
<link href="https://fonts.googleapis.com/css2?family=Lato&display=swap" rel="stylesheet">
<style>

:root {
  --header-background: #ffffff;
  --button-background: #75411c;
  --button-background-2: #a86527;
  --button-hover-background: #75411c;
  --button-hover-background-2: #a86527;
  --button-text-color: #fff;
  --link-color: #24778c;
  --link-hover-color: #24778c;
  --link-text-decoration: none; /* text field */
  --hover-link-text-decoration: underline; /* text field */
  --menu-background: #0e353e;
  --menu-background-2: #164f5d;
  --menu-text-color: #fff;
  --menu-active-hover-background: #24778c;
  --menu-active-hover-text-color: #fff;
  --top-menu-background: #eff2f4;
  --top-menu-link-color: #24778c;
  --top-menu-link-hover-color: #164f5d;
  --accent-color: #75411c;
  --accent-color-2: #a86527;
  --sidebar-h3-color: #24778c;
  --light-gray-color:#eff2f4;
  --light-gray-link-color:#eff2f4;
  --light-gray-link-hover-color:#eff2f4;
  --list-item-bottom-border: solid 1px #eff2f4;
  --border-radius: 0;
  --border-radius-small-items: 0;
  --H1-font: bold 2em/1.3 "Lato",sans-serif;
  --H2-font:  bold 1.3em/1.3 "Lato",sans-serif;
  --H3-font:  bold uppercase 1.1em/1.3 "Lato",sans-serif;
  --body-font: 15px "Lato",sans-serif;
  --menu-font: 1em "Lato", sans-serif;
  --box-shadow: 0px 0px 1px 0px #eff2f4; 
  --body-background: #b48d7a;
  --body-background-2: #b48d7a;
  --body-font-color: #000;

}


body {
	font: var(--body-font);
    background: var(--body-background);
	color: var(--body-font-color);
	 
		
	background: -moz-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -webkit-gradient(left top,left bottom,color-stop(0%, var(--body-background)),color-stop(100%, var(--body-background-2)));
    background: -webkit-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -o-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -ms-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: linear-gradient(to bottom, var(--body-background) 0%, var(--body-background-2) 100%);
		
    background-attachment: fixed;
    background-size: cover;
}

</style>
<link rel="stylesheet" href="https://www.etfdailynews.com/wp-content/themes/responsalambre/style.css?v=2021abcdefghij" type="text/css" media="screen">
<link href="https://www.etfdailynews.com/feed/" rel="alternate" title="ETF Daily News RSS Feed" type="application/rss+xml" />
<link href="https://www.etfdailynews.com/feed/atom/" rel="alternate" title="ETF Daily News Atom Feed" type="application/atom+xml" />
<link href="https://www.etfdailynews.com/xmlrpc.php" rel="pingback" />
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ETF Daily News &raquo; Comerica Bank Has $12.01 Million Stake in United Therapeutics Co. (NASDAQ:UTHR) Comments Feed" href="https://www.etfdailynews.com/2022/02/27/comerica-bank-has-12-01-million-stake-in-united-therapeutics-co-nasdaquthr/feed/" />
<link rel='stylesheet' id='wp-block-library-group-css' href='https://www.etfdailynews.com/wp-content/plugins/bwp-minify/min/?f=wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://www.etfdailynews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.etfdailynews.com/wp-json/wp/v2/posts/3789" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.etfdailynews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.etfdailynews.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.9.1" />
<link rel="canonical" href="https://www.etfdailynews.com/2022/02/27/comerica-bank-has-12-01-million-stake-in-united-therapeutics-co-nasdaquthr/" />
<link rel='shortlink' href='https://www.etfdailynews.com/?p=3789' />
<link rel="alternate" type="application/json+oembed" href="https://www.etfdailynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F02%2F27%2Fcomerica-bank-has-12-01-million-stake-in-united-therapeutics-co-nasdaquthr%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.etfdailynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F02%2F27%2Fcomerica-bank-has-12-01-million-stake-in-united-therapeutics-co-nasdaquthr%2F&#038;format=xml" />
<link rel="manifest" href="https://www.etfdailynews.com/manifest.json"><link rel="amphtml" href="https://www.etfdailynews.com/2022/02/27/comerica-bank-has-12-01-million-stake-in-united-therapeutics-co-nasdaquthr/amp/" />

<title>Comerica Bank Has $12.01 Million Stake in United Therapeutics Co. (NASDAQ:UTHR) - ETF Daily News</title>
<meta name="description" content="Read Comerica Bank Has $12.01 Million Stake in United Therapeutics Co. (NASDAQ:UTHR) at ETF Daily News" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="description" content="Comerica Bank lifted its stake in shares of United Therapeutics Co. (NASDAQ:UTHR &#8211; Get Rating) by 83.9% in the 3rd quarter, according to the company in its most recent filing with the Securities &amp; Exchange Commission. The firm owned 61,136 shares of the biotechnology company&#8217;s stock after buying an additional 27,891 shares during the quarter. [&hellip;]" />
<meta name="author" content="MarketBeat News">
<meta name="news_keywords" content="United Therapeutics,NASDAQ:UTHR,UTHR,Medical,91307C10,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="keywords" content="United Therapeutics,NASDAQ:UTHR,UTHR,Medical,91307C10,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="ticker" content="NASDAQ:UTHR" />
<meta name="contentType" content="article">

<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@MarketBeatCom" />
<meta name="twitter:title" content="Comerica Bank Has $12.01 Million Stake in United Therapeutics Co. (NASDAQ:UTHR)" />
<meta name="twitter:description" content="Comerica Bank lifted its stake in shares of United Therapeutics Co. (NASDAQ:UTHR &#8211; Get Rating) by 83.9% in the 3rd quarter, according to the company in its most recent filing with the Securities &amp; Exchange Commission. The firm owned 61,136 shares of the biotechnology company&#8217;s stock after buying an additional 27,891 shares during the quarter. [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/0000950133-04-004154_W68366W6836600.GIF&amp;w=240&amp;h=240&amp;zc=2" />

<meta property="og:title" content="Comerica Bank Has $12.01 Million Stake in United Therapeutics Co. (NASDAQ:UTHR)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.etfdailynews.com/2022/02/27/comerica-bank-has-12-01-million-stake-in-united-therapeutics-co-nasdaquthr/" />
<meta property="og:image" content="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/0000950133-04-004154_W68366W6836600.GIF&amp;w=240&amp;h=240&amp;zc=2" />
<meta property="og:image:width" content="240" />
<meta property="og:image:height" content="240" />
<meta property="og:description" content="Comerica Bank lifted its stake in shares of United Therapeutics Co. (NASDAQ:UTHR &#8211; Get Rating) by 83.9% in the 3rd quarter, according to the company in its most recent filing with the Securities &amp; Exchange Commission. The firm owned 61,136 shares of the biotechnology company&#8217;s stock after buying an additional 27,891 shares during the quarter. [&hellip;]" />
<meta property="og:site_name" content="ETF Daily News" />
<meta property="og:locale" content="en_US" />

<meta property="article:published_time" content="2022-02-27T16:58:41+0000" />
<meta property="article:modified_time" content="2022-02-27T16:58:41+0000" />
<meta property="article:tag" content="NASDAQ:UTHR" />
<meta property="article:tag" content="United Therapeutics,NASDAQ:UTHR,UTHR,Medical,91307C10,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta property="article:section" content="Markets" />


<script type='text/javascript'>var PopupAdChannel=''; </script>
<link rel="manifest" href="/manifest.json">
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
<script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'etfdailynews.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "",
      safari_web_id: '', 
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}  </script>
<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>
<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=2021"></script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21771534901/ETF', [[728, 90]], 'div-gpt-ad-1640203754554-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-8025563-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-8025563-1');
</script>
<script src="https://ef53b36683c44880ae01202dedb7e921.js.ubembed.com" async></script>
</head>
<body>
<div id="wrap">
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=60"></script>
<a class="skip-link scroll" href="#main">Skip to main content</a>
<header>
<div class="width-limiter background-light top-menu-bar">
<div style='color:#222;text-align:right;'>
</div>
</div>

<div class="width-limiter top-mobile-menu" id='mobile-logo-bar'>
<label for="nav-trigger" style="display:inline-block; width:30vw; color:#12424d;vertical-align:middle;">&#9776;</label>
<a style='vertical-align:middle;width:33vw;display:inline-block;text-align:center;padding:5px;' href="https://www.etfdailynews.com"><img style='width:120px' src="https://www.etfdailynews.com/wp-content/uploads/2022/02/etfdailynews.png" alt="ETF Daily News logo" width="303" height="96"></a>
</div>
<div class="width-limiter" style="min-height: 5px;" id='mobile-menu-bar'>
<input type="checkbox" id="nav-trigger" class="navOpen" />
<div class="mobile-nav nice-scroll">
<nav class="mobile-menu" aria-label="Category Mobile Menu"><ul id="menu-main-menu" class="menu"><li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://www.etfdailynews.com/category/markets/analyst-articles-us/">Analyst Ratings</a></li>
<li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.etfdailynews.com/category/markets/cryptocurrencies/">Crypto</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://www.etfdailynews.com/category/markets/earnings-articles-single/">Earnings</a></li>
<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://www.etfdailynews.com/category/markets/insider-trades/">Insider Trades</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://www.etfdailynews.com/category/markets/ipo-articles/">IPOs</a></li>
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://www.etfdailynews.com/category/markets/options-articles/">Options</a></li>
</ul></nav>
<form class="mobile-search" id="mobileSearchForm" action="https://www.etfdailynews.com/" method="get">
<div class="search">
<input id="s" style='margin-left:0;' class="searchinput" aria-label="Search Keywords" name="s" onclick="this.value='';" type="text" />
<input class="searchsubmit" type="submit" value="SEARCH" />
</div>
</form>
<div>
</div>
</div>
</div>

<div class="width-limiter add-padding flex-container">
<a class="logo-link flex-logo" id="header-logo-link" href="https://www.etfdailynews.com" title="ETF Daily News"><img id="logo" src="https://www.etfdailynews.com/wp-content/uploads/2022/02/etfdailynews.png" alt="ETF Daily News logo" width="303" height="96"></a>

<div id="AlternateHeaderUnit" class="flex-header-ad">
<div id='div-gpt-ad-1640203754554-0' style='min-width: 728px; min-height: 90px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1640203754554-0'); });
  </script></div>
</div>

</div> 
<div id="menu">
<div class="width-limiter flex-container" id="nav-main">

<div class="flex-nav">
<nav class="navigation" aria-label="Main Menu"><ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://www.etfdailynews.com/category/markets/analyst-articles-us/">Analyst Ratings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.etfdailynews.com/category/markets/cryptocurrencies/">Crypto</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://www.etfdailynews.com/category/markets/earnings-articles-single/">Earnings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://www.etfdailynews.com/category/markets/insider-trades/">Insider Trades</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://www.etfdailynews.com/category/markets/ipo-articles/">IPOs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://www.etfdailynews.com/category/markets/options-articles/">Options</a></li>
</ul></nav>
</div>
<form class="flex-search" id="searchform" action="https://www.etfdailynews.com/" method="get">
<div class="search">
<input id="s-main" class="searchinput" name="s" aria-label="Search Keywords" onclick="this.value='';" type="text" />
<input class="searchsubmit" type="submit" value="SEARCH" />
</div>
</form>
</div> 
</div> 
</header> 
<div class="width-limiter main-content flex-container">
<main class="flex-main" id="main">
<article itemscope itemtype="http://schema.org/NewsArticle">
<link itemprop="mainEntityOfPage" href="https://www.etfdailynews.com/2022/02/27/comerica-bank-has-12-01-million-stake-in-united-therapeutics-co-nasdaquthr/" />
<h1 itemprop="headline" class="page-title">Comerica Bank Has $12.01 Million Stake in United Therapeutics Co. (NASDAQ:UTHR)</h1>
<p class="postmeta">
Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://www.etfdailynews.com/author/marketbeat/" title="Posts by MarketBeat News" rel="author">MarketBeat News</a></span></span> on <span itemprop="datePublished dateModified" content="2022-02-27T16:58:41+0000">Feb 27th, 2022</span>
</p>
<div class="social-shares">
<a title="Share on Twitter" rel="noopener nofollow" target="_blank" style="background: #1DA1F2;" href="https://twitter.com/intent/tweet?original_referer=https%3A%2F%2Fwww.etfdailynews.com&ref_src=twsrc%5Etfw&text=Comerica%20Bank%20Has%20%2412.01%20Million%20Stake%20in%20United%20Therapeutics%20Co.%20%28NASDAQ%3AUTHR%29%20%24UTHR&tw_p=tweetbutton&url=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F02%2F27%2Fcomerica-bank-has-12-01-million-stake-in-united-therapeutics-co-nasdaquthr%2F&via=etfdailynews"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z" /></svg></span><span class="share-title">Share on Twitter</span></a>
<a title="Share on Facebook" rel="noopener nofollow" target="_blank" style="background:#4267B2;" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F02%2F27%2Fcomerica-bank-has-12-01-million-stake-in-united-therapeutics-co-nasdaquthr%2F"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z" /></svg></span><span class="share-title">Share on Facebook</span></a>
<a title="Share on LinkedIn" rel="noopener nofollow" target="_blank" style="background: #0067b1;" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F02%2F27%2Fcomerica-bank-has-12-01-million-stake-in-united-therapeutics-co-nasdaquthr%2F"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z" /></svg></span><span class="share-title">Share on LinkedIn</span></a>
<a title="Share on Stocktwits" rel="noopener nofollow" style="background:#228dff;" href="https://api.stocktwits.com/widgets/share?via=MarketBeat&amp;body=Comerica%20Bank%20Has%20%2412.01%20Million%20Stake%20in%20United%20Therapeutics%20Co.%20%28NASDAQ%3AUTHR%29%20%24UTHR" title="Share on StockTwits"><span class="share-button"><svg style="fill:#fff;" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="24" height="24" viewBox="0 0 30 30" style="enable-background:new 0 0 30 30;" xml:space="preserve"><polygon class="st0" points="21.98,17.75 21.98,13.29 14.54,9.67 21.98,6.19 21.98,1.84 9.02,8.45 9.02,11.12 " /><polygon class="st0" points="9.07,13.19 9.07,17.65 16.49,21.27 9.07,24.76 9.07,29.1 21.98,22.49 21.98,19.82 " /></svg></span><span class="share-title">Share on Stocktwits</span></a>
</div>
<div style="clear:both"></div>

<div class="entry" itemprop="articleBody">

<p><img height="150" width="250" src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&h=150&zc=2&src=https://www.marketbeat.com/logos/0000950133-04-004154_W68366W6836600.GIF" alt="United Therapeutics logo" title="United Therapeutics" class="companylogo" />Comerica Bank lifted its stake in shares of United Therapeutics Co. (NASDAQ:UTHR &#8211; <a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=UTHR&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=UTHR&#038;utm_content=text_link'>Get Rating</a>) by 83.9% in the 3rd quarter, according to the company in its most recent filing with the Securities &amp; Exchange Commission. The firm owned 61,136 shares of the biotechnology company&#8217;s stock after buying an additional 27,891 shares during the quarter. Comerica Bank owned about 0.14% of United Therapeutics worth $12,010,000 as of its most recent filing with the Securities &amp; Exchange Commission. </p>
<p>A number of other hedge funds and other institutional investors have also bought and sold shares of UTHR. Deutsche Bank AG grew its position in United Therapeutics by 542.3% in the 3rd quarter. Deutsche Bank AG now owns 843,437 shares of the biotechnology company&#8217;s stock valued at $155,681,000 after purchasing an additional 712,117 shares during the period. Perceptive Advisors LLC lifted its stake in United Therapeutics by 252.5% during the 2nd quarter. Perceptive Advisors LLC now owns 616,802 shares of the biotechnology company&#8217;s stock valued at $110,660,000 after acquiring an additional 441,802 shares in the last quarter. Epoch Investment Partners Inc. bought a new position in United Therapeutics during the 3rd quarter valued at $47,154,000. Two Sigma Advisers LP lifted its stake in United Therapeutics by 958.4% during the 3rd quarter. Two Sigma Advisers LP now owns 237,101 shares of the biotechnology company&#8217;s stock valued at $43,764,000 after acquiring an additional 214,700 shares in the last quarter. Finally, Bank of Nova Scotia lifted its stake in United Therapeutics by 6,128.3% during the 3rd quarter. Bank of Nova Scotia now owns 177,196 shares of the biotechnology company&#8217;s stock valued at $32,707,000 after acquiring an additional 174,351 shares in the last quarter. 96.15% of the stock is owned by institutional investors and hedge funds. </p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
<input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-ETF Daily News" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:UTHR" /> <label for="InPostRegistrationEmail">Get <b>United Therapeutics</b> alerts:</label>
<div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 0.9em;line-height: 1em;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" class="button" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;font-size: 0.9em;font-weight: 700;line-height: 1em;padding: 6px 18px"></div>
</form>
<div id="ShowSuggestionInPost"></div>
<p>In other news, EVP Paul A. Mahon sold 6,000 shares of the business&#8217;s stock in a transaction dated Thursday, December 16th. The stock was sold at an average price of $195.53, for a total transaction of $1,173,180.00. The sale was disclosed in a document filed with the Securities &amp; Exchange Commission, which is accessible through <a href='http://www.sec.gov/Archives/edgar/data/1082554/000112760221031381/xslF345X03/form4.xml' target='_blank' rel="noopener">this hyperlink</a>. Also, CEO Martine A. Rothblatt sold 3,082 shares of the business&#8217;s stock in a transaction dated Monday, December 27th. The stock was sold at an average price of $213.31, for a total value of $657,421.42. The disclosure for this sale can be found <a href='http://www.sec.gov/Archives/edgar/data/1082554/000112760221031936/xslF345X03/form4.xml' target='_blank' rel="noopener">here</a>. Insiders have sold a total of 48,328 shares of company stock valued at $9,663,776 in the last ninety days. Insiders own 12.10% of the company&#8217;s stock. </p>
<p>
<div class="in-article-ad" class="width:340px;">
<iframe src="https://marketbeat.com/scripts/336x280AdNewsSites.ashx" width="336" height="280" frameborder="no" title="Offer"></iframe>
</div>
<a href='https://www.pricetargets.com/NASDAQ/UTHR/' target='_blank' rel="noopener">UTHR stock</a> opened at $168.00 on Friday. The company has a quick ratio of 7.15, a current ratio of 7.46 and a debt-to-equity ratio of 0.21. The firm has a market capitalization of $7.57 billion, a PE ratio of 17.02, a PEG ratio of 7.21 and a beta of 0.57. United Therapeutics Co. has a twelve month low of $155.71 and a twelve month high of $218.38. The stock has a 50-day simple moving average of $202.50 and a two-hundred day simple moving average of $199.48. </p>
<p>United Therapeutics (NASDAQ:UTHR &#8211; <a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=UTHR&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=UTHR&#038;utm_content=text_link'>Get Rating</a>) last posted its earnings results on Thursday, February 24th. The biotechnology company reported $2.35 earnings per share for the quarter, missing the Zacks&#8217; consensus estimate of $3.77 by ($1.42). The company had revenue of $415.20 million for the quarter, compared to analysts&#8217; expectations of $427.59 million. United Therapeutics had a net margin of 27.94% and a return on equity of 12.93%. The firm&#8217;s quarterly revenue was up 7.9% compared to the same quarter last year. During the same period in the previous year, the firm earned $2.19 EPS. On average, equities research analysts anticipate that United Therapeutics Co. will post 11.36 EPS for the current fiscal year. </p>
<p>A number of equities research analysts have recently commented on the company. <a style='font-weight:bold' href='https://report.stocknews.com/sign-up/ticker/?ticker=UTHR&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=UTHR&#038;utm_content=text_link'>StockNews.com</a> cut United Therapeutics from a &#8220;strong-buy&#8221; rating to a &#8220;buy&#8221; rating in a research note on Friday. BTIG Research assumed coverage on United Therapeutics in a research note on Friday, February 11th. They issued a &#8220;neutral&#8221; rating on the stock. LADENBURG THALM/SH SH lowered their price objective on United Therapeutics from $231.00 to $203.00 and set a &#8220;buy&#8221; rating on the stock in a research note on Friday. Finally, HC Wainwright restated a &#8220;buy&#8221; rating on shares of United Therapeutics in a research note on Friday. One research analyst has rated the stock with a sell rating, one has given a hold rating and five have assigned a buy rating to the company. According to MarketBeat.com, the stock currently has an average rating of &#8220;Buy&#8221; and an average target price of $212.00.</p>
<p><strong>United Therapeutics Profile</strong> (<a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=UTHR&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=UTHR&#038;utm_content=text_link'>Get Rating</a>)</p>
<p>United Therapeutics Corp. operates as a biotechnology company which engages in the development and commercialization of products for patients with chronic and life-threatening diseases. The firm markets and sells commercial therapies to treat pulmonary arterial hypertension and high-risk neuroblastoma.</p>
<p><strong>Featured Stories</strong></p>
<ul>
<li><a href='https://report.stocknews.com/sign-up/ticker/?ticker=UTHR&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=UTHR&#038;utm_content=text_link' target='_blank' rel="noopener">Get a free copy of the StockNews.com research report on United Therapeutics (UTHR)</a></li>
<li><a href='https://www.marketbeat.com/originals/3-glass-stocks-that-could-sharpen-your-portfolio/' target='_blank' rel="noopener">3 Glass Stocks that Could Sharpen Your Portfolio</a></li>
<li><a href='https://www.marketbeat.com/originals/the-top-3-stocks-to-buy-in-march/' target='_blank' rel="noopener">The Top 3 Stocks to Buy in March</a></li>
<li><a href='https://www.marketbeat.com/originals/marketbeat-week-in-review-2-21-2-25/' target='_blank' rel="noopener">MarketBeat: Week in Review 2/21 – 2/25</a></li>
<li><a href='https://www.marketbeat.com/originals/volatility-spikes-on-russian-aggression-in-ukraine/' target='_blank' rel="noopener">Volatility Spikes On Russian Aggression In Ukraine </a></li>
<li><a href='https://www.marketbeat.com/originals/pets-are-big-business-4-big-ticket-pet-stocks-to-add-to-your-portfolio/' target='_blank' rel="noopener">Pets Are Big Business: 4 Big-Ticket Pet Stocks to Add to Your Portfolio</a></li>
</ul>
<p></p>
<p><strong>Want to see what other hedge funds are holding UTHR?</strong> <a href='https://www.holdingschannel.com/hedge-funds/holding-uthr/'>Visit HoldingsChannel.com</a> to get the latest 13F filings and insider trades for United Therapeutics Co. (NASDAQ:UTHR &#8211; <a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=UTHR&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=UTHR&#038;utm_content=text_link'>Get Rating</a>).</p>
<p style='text-align:center'><img src='https://www.marketbeat.com/scripts/SECFilingChart.ashx?Prefix=NASDAQ&#038;Symbol=UTHR' alt='Institutional Ownership by Quarter for United Therapeutics (NASDAQ:UTHR)' width='650' height='350' /></p>
<p></p>
<p><strong>Want More Great Investing Ideas?</strong></p>
<ul>
<li><a href="https://report.stocknews.com/free-report/3stocks/?formplacement=artbottom3s_etf" target="_blank"><span style="color:#d32f2f;">3 Stocks to DOUBLE This Year</span></a></li>
<li><a href="https://www.marketbeat.com/newsletter/PDFoffer.aspx?offer=newyear&RegistrationCode=ETFDailyNews" target="_blank"><span style="color:#d32f2f;">The 10 Best Stocks to Own in 2022</span></a></li>
<li><a href="https://www.marketbeat.com/newsletter/PDFoffer.aspx?offer=buyandhold&RegistrationCode=ETFDailyNews" target="_blank"><span style="color:#d32f2f;">7 Stocks to Buy and Hold Forever</span></a></li>
<li><a href="https://report.stocknews.com/9-must-have-stocks/?formplacement=artbottom9g_etf" target="_blank"><span style="color:#d32f2f;">9 "MUST OWN" Growth Stocks</span></a></li>
</ul>





<p style="clear:both"><strong>Receive News &amp; Ratings for United Therapeutics Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for United Therapeutics and related companies with <a href="/daily-email-updates-basic/?symbol=NASDAQ:UTHR&c=United+Therapeutics" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" aria-label="Your Email Address" class="signup" />
<input type="hidden" id="Hidden3" name="RegistrationCode" value="ETF Daily News-Footer" />
<input type="hidden" id="Hidden4" name="RegisterTicker" value="NASDAQ:UTHR" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>

</div> 


<div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=500&h=300&zc=2&src=https://www.marketbeat.com/logos/0000950133-04-004154_W68366W6836600.GIF" />
<meta itemprop="width" content="500">
<meta itemprop="height" content="300">
</div>
<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://www.etfdailynews.com/wp-content/uploads/2022/02/etfdailynews.png">
<meta itemprop="width" content="303">
<meta itemprop="height" content="96">
</div>
<meta itemprop="name" content="ETF Daily News" />
<meta itemprop="url" content="https://etfdailynews.com" />
</div>

</article>

<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx" title="More Headlines"></iframe>


<nav id="prevnext">
<a href="https://www.etfdailynews.com/2022/02/27/patriot-financial-group-insurance-agency-llc-boosts-stock-holdings-in-ishares-1-3-year-treasury-bond-etf-nasdaqshy/" rel="prev"><div class="previous"><h2 class="h4">&laquo; PREVIOUS HEADLINE</h2><p>Patriot Financial Group Insurance Agency LLC Boosts Stock Holdings in iShares 1-3 Year Treasury Bond ETF (NASDAQ:SHY)</p></div></a> <a href="https://www.etfdailynews.com/2022/02/27/moors-cabot-inc-makes-new-2-44-million-investment-in-seagate-technology-holdings-plc-nasdaqstx/" rel="next"><div class="next"><h2 class="h4">NEXT HEADLINE &raquo;</h2><p>Moors &#038; Cabot Inc. Makes New $2.44 Million Investment in Seagate Technology Holdings plc (NASDAQ:STX)</p></div></a>
</nav>
<div id="latest-news">
<h2>You might be interested in:</h2>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/home-depot-logo.gif&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Vickerman Investment Advisors Inc. Invests $227,000 in The Home Depot, Inc. " />
</div></div>

<a href="https://www.etfdailynews.com/2022/02/27/vickerman-investment-advisors-inc-invests-227000-in-the-home-depot-inc-nysehd/" rel="bookmark">Vickerman Investment Advisors Inc. Invests $227,000 in The Home Depot, Inc. </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/cisco-systems-inc-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="UBS Asset Management Americas Inc. Has $1.45 Billion Stock Position in Cisco Systems, Inc. " />
</div></div>

<a href="https://www.etfdailynews.com/2022/02/27/ubs-asset-management-americas-inc-has-1-45-billion-stock-position-in-cisco-systems-inc-nasdaqcsco/" rel="bookmark">UBS Asset Management Americas Inc. Has $1.45 Billion Stock Position in Cisco Systems, Inc. </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/general-electric-company-logo.png&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="First Command Bank Sells 19,812 Shares of General Electric " />
</div></div>

<a href="https://www.etfdailynews.com/2022/02/27/first-command-bank-sells-19812-shares-of-general-electric-nysege/" rel="bookmark">First Command Bank Sells 19,812 Shares of General Electric </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/unitedhealth-group-incorporated-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Strategy Asset Managers LLC Grows Position in UnitedHealth Group Incorporated " />
</div></div>

<a href="https://www.etfdailynews.com/2022/02/27/strategy-asset-managers-llc-grows-position-in-unitedhealth-group-incorporated-nyseunh/" rel="bookmark">Strategy Asset Managers LLC Grows Position in UnitedHealth Group Incorporated </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/bristol-myers-squibb-co-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="WealthPLAN Partners LLC Reduces Stock Holdings in Bristol-Myers Squibb " />
</div></div>

<a href="https://www.etfdailynews.com/2022/02/27/wealthplan-partners-llc-reduces-stock-holdings-in-bristol-myers-squibb-nysebmy/" rel="bookmark">WealthPLAN Partners LLC Reduces Stock Holdings in Bristol-Myers Squibb </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/samp;p-global-inc-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="S&#038;P Global Inc.  Shares Purchased by Homrich &#038; Berg" />
</div></div>

<a href="https://www.etfdailynews.com/2022/02/27/sp-global-inc-nysespgi-shares-purchased-by-homrich-berg/" rel="bookmark">S&#038;P Global Inc. Shares Purchased by Homrich &#038; Berg</a>
</div>
</div>

<br>
</main> 
<aside class="flex-sidebar">
<div class="flex-container">
<div class="sidebar-section">
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx" width="336" height="600" frameborder="no" title="More Articles"></iframe><br><br>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>

<br><br>


<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>

<br><br>

</div>
<div class="sidebar-section">


<div class="sidebar-email">
<h3>Daily Ratings &amp; News for United Therapeutics</h3>
Complete the form below to receive the latest headlines and analysts' recommendations for United Therapeutics with our free daily email newsletter:<br />
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="RegisterEmailSidebar" style='width:100%' name="RegisterEmail" type="email" placeholder="Your Email Address" aria-label="Your Email Address">
<input type="hidden" id="Hidden7" name="RegistrationCode" value="ETF Daily News-Sidebar">
<input type="hidden" id="Hidden8" name="RegisterTicker" value="NASDAQ:UTHR" /> <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:100%;height:30px">
<div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
</form>
</div>


<br>
<a style="background: #075A8D;color: #fff;padding: 5px 7px 4px;border-radius: 3px;font-size: 12px;text-decoration: none;" href="https://twitter.com/intent/follow?original_referer=https%3A%2F%2Fwww.etfdailynews.com%2F&ref_src=twsrc%5Etfw&screen_name=etfdailynews" target="_blank" rel="noopener nofollow">
<svg style="width: 13px;vertical-align: middle;margin-right: 4px;fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z" /></svg> Follow @etfdailynews</a>



<br />
<div>
<h3>Recent News</h3>
<ul>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/vickerman-investment-advisors-inc-invests-227000-in-the-home-depot-inc-nysehd/">Vickerman Investment Advisors Inc. Invests $227,000 in The Home Depot, Inc. (NYSE:HD)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/ubs-asset-management-americas-inc-has-1-45-billion-stock-position-in-cisco-systems-inc-nasdaqcsco/">UBS Asset Management Americas Inc. Has $1.45 Billion Stock Position in Cisco Systems, Inc. (NASDAQ:CSCO)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/first-command-bank-sells-19812-shares-of-general-electric-nysege/">First Command Bank Sells 19,812 Shares of General Electric (NYSE:GE)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/strategy-asset-managers-llc-grows-position-in-unitedhealth-group-incorporated-nyseunh/">Strategy Asset Managers LLC Grows Position in UnitedHealth Group Incorporated (NYSE:UNH)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/wealthplan-partners-llc-reduces-stock-holdings-in-bristol-myers-squibb-nysebmy/">WealthPLAN Partners LLC Reduces Stock Holdings in Bristol-Myers Squibb (NYSE:BMY)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/sp-global-inc-nysespgi-shares-purchased-by-homrich-berg/">S&#038;P Global Inc. (NYSE:SPGI) Shares Purchased by Homrich &#038; Berg</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/principal-financial-group-inc-nasdaqpfg-shares-sold-by-kingsview-wealth-management-llc/">Principal Financial Group, Inc. (NASDAQ:PFG) Shares Sold by Kingsview Wealth Management LLC</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/kingsview-wealth-management-llc-grows-stock-holdings-in-lyondellbasell-industries-nyselyb/">Kingsview Wealth Management LLC Grows Stock Holdings in LyondellBasell Industries (NYSE:LYB)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/vpr-management-llc-takes-position-in-vanguard-energy-etf-nysearcavde/">VPR Management LLC Takes Position in Vanguard Energy ETF (NYSEARCA:VDE)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/first-command-bank-reduces-position-in-pfizer-inc-nysepfe/">First Command Bank Reduces Position in Pfizer Inc. (NYSE:PFE)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/birmingham-capital-management-co-inc-al-has-2-22-million-position-in-general-electric-nysege/">Birmingham Capital Management Co. Inc. AL Has $2.22 Million Position in General Electric (NYSE:GE)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/moors-cabot-inc-sells-518-shares-of-csx-co-nasdaqcsx-2/">Moors &#038; Cabot Inc. Sells 518 Shares of CSX Co. (NASDAQ:CSX)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/moors-cabot-inc-sells-518-shares-of-csx-co-nasdaqcsx/">Moors &#038; Cabot Inc. Sells 518 Shares of CSX Co. (NASDAQ:CSX)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/wealthplan-partners-llc-increases-stock-holdings-in-nextera-energy-inc-nysenee/">WealthPLAN Partners LLC Increases Stock Holdings in NextEra Energy, Inc. (NYSE:NEE)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/financial-advisors-network-inc-acquires-2514-shares-of-robert-half-international-inc-nyserhi/">Financial Advisors Network Inc. Acquires 2,514 Shares of Robert Half International Inc. (NYSE:RHI)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/patriot-financial-group-insurance-agency-llc-purchases-1132-shares-of-spdr-blackstone-senior-loan-etf-nysearcasrln/">Patriot Financial Group Insurance Agency LLC Purchases 1,132 Shares of SPDR Blackstone Senior Loan ETF (NYSEARCA:SRLN)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/the-hartford-financial-services-group-inc-nysehig-shares-sold-by-balyasny-asset-management-llc/">The Hartford Financial Services Group, Inc. (NYSE:HIG) Shares Sold by Balyasny Asset Management LLC</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/ubs-asset-management-americas-inc-acquires-406091-shares-of-broadcom-inc-nasdaqavgo/">UBS Asset Management Americas Inc. Acquires 406,091 Shares of Broadcom Inc. (NASDAQ:AVGO)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/ubs-asset-management-americas-inc-has-1-07-billion-stock-holdings-in-the-coca-cola-company-nyseko/">UBS Asset Management Americas Inc. Has $1.07 Billion Stock Holdings in The Coca-Cola Company (NYSE:KO)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/02/27/lyondellbasell-industries-nyselyb-shares-acquired-by-kingsview-wealth-management-llc/">LyondellBasell Industries (NYSE:LYB) Shares Acquired by Kingsview Wealth Management LLC</a></li>
</ul>
</div>
</div>
</div>

</aside>
<div style="clear: both;"></div>
</div> 
<footer class="full-width">
<div class="width-limiter flex-container">
<div id="footer-info" class="add-padding flex-nav">
</div>
<span id="copyright" class="add-padding flex-copyright">
&copy; 2018-2022 <a href="https://www.etfdailynews.com">ETF Daily News</a>
</span>
</div>

<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/standalone/viewcount.ashx?ArticleHistoryID=85668893&PostDate=2022-2-27&type=f&id=11227974&domain=www.etfdailynews.com&referrer=' + encodeURIComponent(document.referrer) + '" alt="" width="1" height="1" style="float:left;" />');</script>

</footer>
</div>

<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1" alt=""></noscript>


<script type="text/javascript">
var sc_project=12682890; 
var sc_invisible=1; 
var sc_security="f2745ebe"; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/12682890/0/f2745ebe/1/" height="1" width="1"  alt=""></noscript>

</body>
</html>
