<!doctype html>
<html lang="en">
<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="theme-color" content="#b71c32" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">

<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script>
<link rel="preconnect" href="https://fonts.gstatic.com">
<link href="https://fonts.googleapis.com/css2?family=Copse&family=Lato&display=swap" rel="stylesheet">
<style>

:root {
  --header-background: #ffffff;
  --button-background: #b71c32;
  --button-background-2: #88021d;
  --button-hover-background: #b71c32;
  --button-hover-background-2: #b71c32;
  --button-text-color: #fff;
  --link-color: #257192;
  --link-hover-color: #288aa3;
  --link-text-decoration: none; /* text field */
  --hover-link-text-decoration: underline; /* text field */
  --menu-background: #111111;
  --menu-background-2: #111111;
  --menu-text-color: #fff;
  --menu-active-hover-background: #257192;
  --menu-active-hover-text-color: #fff;
  --top-menu-background: #eff2f4;
  --top-menu-link-color: #257192;
  --top-menu-link-hover-color: #164f5d;
  --accent-color: #257192;
  --accent-color-2: #257192;
  --sidebar-h3-color: #257192;
  --light-gray-color:#eff2f4;
  --light-gray-link-color:#eff2f4;
  --light-gray-link-hover-color:#eff2f4;
  --list-item-bottom-border: solid 1px #eff2f4;
  --border-radius: 3px;
  --border-radius-small-items: 1px;
  --H1-font: 2.1em/1.3 "Copse",serif;
  --H2-font:  1.4em/1.3 "Copse",serif;
  --H3-font:  bold uppercase 1.1em/1.3 "Lato",sans-serif;
  --body-font: 15px "Lato",sans-serif;
  --menu-font: 1em "Lato", sans-serif;
  --box-shadow: 0px 0px 1px 0px #eff2f4; 
  --body-background: #257192;
  --body-background-2: #111111;
  --body-font-color: #111111;

}


body {
	font: var(--body-font);
    background: var(--body-background);
	color: var(--body-font-color);
	 
		
	background: -moz-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -webkit-gradient(left top,left bottom,color-stop(0%, var(--body-background)),color-stop(100%, var(--body-background-2)));
    background: -webkit-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -o-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -ms-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: linear-gradient(to bottom, var(--body-background) 0%, var(--body-background-2) 100%);
		
    background-attachment: fixed;
    background-size: cover;
}

</style>
<link rel="stylesheet" href="https://www.etfdailynews.com/wp-content/themes/responsalambre/style.css?v=2021abcdefghij" type="text/css" media="screen">
<link href="https://www.etfdailynews.com/feed/" rel="alternate" title="ETF Daily News RSS Feed" type="application/rss+xml" />
<link href="https://www.etfdailynews.com/feed/atom/" rel="alternate" title="ETF Daily News Atom Feed" type="application/atom+xml" />
<link href="https://www.etfdailynews.com/xmlrpc.php" rel="pingback" />
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ETF Daily News &raquo; Comparing AEA-Bridges Impact (NYSE:IMPX) &amp; Arcimoto (NASDAQ:FUV) Comments Feed" href="https://www.etfdailynews.com/2022/04/23/comparing-aea-bridges-impact-nyseimpx-arcimoto-nasdaqfuv/feed/" />
<link rel='stylesheet' id='wp-block-library-group-css' href='https://www.etfdailynews.com/wp-content/plugins/bwp-minify/min/?f=wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://www.etfdailynews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.etfdailynews.com/wp-json/wp/v2/posts/198341" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.etfdailynews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.etfdailynews.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.9.3" />
<link rel="canonical" href="https://www.etfdailynews.com/2022/04/23/comparing-aea-bridges-impact-nyseimpx-arcimoto-nasdaqfuv/" />
<link rel='shortlink' href='https://www.etfdailynews.com/?p=198341' />
<link rel="alternate" type="application/json+oembed" href="https://www.etfdailynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F04%2F23%2Fcomparing-aea-bridges-impact-nyseimpx-arcimoto-nasdaqfuv%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.etfdailynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F04%2F23%2Fcomparing-aea-bridges-impact-nyseimpx-arcimoto-nasdaqfuv%2F&#038;format=xml" />
<link rel="manifest" href="https://www.etfdailynews.com/manifest.json"><link rel="amphtml" href="https://www.etfdailynews.com/2022/04/23/comparing-aea-bridges-impact-nyseimpx-arcimoto-nasdaqfuv/amp/" /><link rel="icon" href="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo_etf-icon-1-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo_etf-icon-1-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo_etf-icon-1-300x300.png" />
<meta name="msapplication-TileImage" content="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo_etf-icon-1-300x300.png" />

<title>Comparing AEA-Bridges Impact (NYSE:IMPX) &amp; Arcimoto (NASDAQ:FUV) - ETF Daily News</title>
<meta name="description" content="Read Comparing AEA-Bridges Impact (NYSE:IMPX) &amp; Arcimoto (NASDAQ:FUV) at ETF Daily News" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="description" content="Arcimoto (NASDAQ:FUV &#8211; Get Rating) and AEA-Bridges Impact (NYSE:IMPX &#8211; Get Rating) are both small-cap auto/tires/trucks companies, but which is the superior business? We will compare the two businesses based on the strength of their valuation, analyst recommendations, institutional ownership, profitability, risk, earnings and dividends. Analyst Ratings This is a summary of current ratings and [&hellip;]" />
<meta name="author" content="MarketBeat News">
<meta name="news_keywords" content="Arcimoto,NASDAQ:FUV,FUV,Auto/Tires/Truck,comparison,review,stock comparison,stock analysis" />
<meta name="keywords" content="Arcimoto,NASDAQ:FUV,FUV,Auto/Tires/Truck,comparison,review,stock comparison,stock analysis" />
<meta name="ticker" content="NASDAQ:FUV" />
<meta name="contentType" content="article">

<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@MarketBeatCom" />
<meta name="twitter:title" content="Comparing AEA-Bridges Impact (NYSE:IMPX) &amp; Arcimoto (NASDAQ:FUV)" />
<meta name="twitter:description" content="Arcimoto (NASDAQ:FUV &#8211; Get Rating) and AEA-Bridges Impact (NYSE:IMPX &#8211; Get Rating) are both small-cap auto/tires/trucks companies, but which is the superior business? We will compare the two businesses based on the strength of their valuation, analyst recommendations, institutional ownership, profitability, risk, earnings and dividends. Analyst Ratings This is a summary of current ratings and [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/aea-bridges-impact-corp-logo.png?v=20211213081102&amp;w=240&amp;h=240&amp;zc=2" />

<meta property="og:title" content="Comparing AEA-Bridges Impact (NYSE:IMPX) &amp; Arcimoto (NASDAQ:FUV)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.etfdailynews.com/2022/04/23/comparing-aea-bridges-impact-nyseimpx-arcimoto-nasdaqfuv/" />
<meta property="og:image" content="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/aea-bridges-impact-corp-logo.png?v=20211213081102&amp;w=240&amp;h=240&amp;zc=2" />
<meta property="og:image:width" content="240" />
<meta property="og:image:height" content="240" />
<meta property="og:description" content="Arcimoto (NASDAQ:FUV &#8211; Get Rating) and AEA-Bridges Impact (NYSE:IMPX &#8211; Get Rating) are both small-cap auto/tires/trucks companies, but which is the superior business? We will compare the two businesses based on the strength of their valuation, analyst recommendations, institutional ownership, profitability, risk, earnings and dividends. Analyst Ratings This is a summary of current ratings and [&hellip;]" />
<meta property="og:site_name" content="ETF Daily News" />
<meta property="og:locale" content="en_US" />

<meta property="article:published_time" content="2022-04-23T14:14:41+0000" />
<meta property="article:modified_time" content="2022-04-23T14:14:41+0000" />
<meta property="article:tag" content="NASDAQ:FUV" />
<meta property="article:tag" content="Arcimoto,NASDAQ:FUV,FUV,Auto/Tires/Truck,comparison,review,stock comparison,stock analysis" />
<meta property="article:section" content="Markets" />


<script type='text/javascript'>var PopupAdChannel=''; </script>
<link rel="manifest" href="/manifest.json">
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
<script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'etfdailynews.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "cca79df0-f0c0-4b3f-906c-d1d378701b61",
      safari_web_id: '', 
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}  </script>
<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>
<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=2021"></script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21771534901/ETF', [728, 90], 'div-gpt-ad-1646836351561-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21771534901/ETF', [336, 280], 'div-gpt-ad-1646836411098-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-8025563-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-8025563-1');
</script>
<script src="https://ef53b36683c44880ae01202dedb7e921.js.ubembed.com" async></script>
</head>
<body>
<div id="wrap">
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=60"></script>
<a class="skip-link scroll" href="#main">Skip to main content</a>
<header>
<div class="width-limiter background-light top-menu-bar">
<div style='color:#222;text-align:right;'>
</div>
</div>

<div class="width-limiter top-mobile-menu" id='mobile-logo-bar'>
<label for="nav-trigger" style="display:inline-block; width:30vw; color:#12424d;vertical-align:middle;">&#9776;</label>
<a style='vertical-align:middle;width:33vw;display:inline-block;text-align:center;padding:5px;' href="https://www.etfdailynews.com"><img style='width:120px' src="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo-02.png" alt="ETF Daily News logo" width="550" height="188"></a>
</div>
<div class="width-limiter" style="min-height: 5px;" id='mobile-menu-bar'>
<input type="checkbox" id="nav-trigger" class="navOpen" />
<div class="mobile-nav nice-scroll">
<nav class="mobile-menu" aria-label="Category Mobile Menu"><ul id="menu-main-menu" class="menu"><li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://www.etfdailynews.com/category/markets/analyst-articles-us/">Analyst Ratings</a></li>
<li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.etfdailynews.com/category/markets/cryptocurrencies/">Crypto</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://www.etfdailynews.com/category/markets/earnings-articles-single/">Earnings</a></li>
<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://www.etfdailynews.com/category/markets/insider-trades/">Insider Trades</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://www.etfdailynews.com/category/markets/ipo-articles/">IPOs</a></li>
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://www.etfdailynews.com/category/markets/options-articles/">Options</a></li>
</ul></nav>
<form class="mobile-search" id="mobileSearchForm" action="https://www.etfdailynews.com/" method="get">
<div class="search">
<input id="s" style='margin-left:0;' class="searchinput" aria-label="Search Keywords" name="s" onclick="this.value='';" type="text" />
<input class="searchsubmit" type="submit" value="SEARCH" />
</div>
</form>
<div>
</div>
</div>
</div>

<div class="width-limiter add-padding flex-container">
<a class="logo-link flex-logo" id="header-logo-link" href="https://www.etfdailynews.com" title="ETF Daily News"><img id="logo" src="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo-02.png" alt="ETF Daily News logo" width="550" height="188"></a>

<div id="AlternateHeaderUnit" class="flex-header-ad">


<div id='div-gpt-ad-1646836351561-0' style='min-width: 728px; min-height: 90px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1646836351561-0'); });
  </script>
</div>
</div>

</div> 
<div id="menu">
<div class="width-limiter flex-container" id="nav-main">

<div class="flex-nav">
<nav class="navigation" aria-label="Main Menu"><ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://www.etfdailynews.com/category/markets/analyst-articles-us/">Analyst Ratings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.etfdailynews.com/category/markets/cryptocurrencies/">Crypto</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://www.etfdailynews.com/category/markets/earnings-articles-single/">Earnings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://www.etfdailynews.com/category/markets/insider-trades/">Insider Trades</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://www.etfdailynews.com/category/markets/ipo-articles/">IPOs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://www.etfdailynews.com/category/markets/options-articles/">Options</a></li>
</ul></nav>
</div>
<form class="flex-search" id="searchform" action="https://www.etfdailynews.com/" method="get">
<div class="search">
<input id="s-main" class="searchinput" name="s" aria-label="Search Keywords" onclick="this.value='';" type="text" />
<input class="searchsubmit" type="submit" value="SEARCH" />
</div>
</form>
</div> 
</div> 
</header> 
<div class="width-limiter main-content flex-container">
<main class="flex-main" id="main">
<article itemscope itemtype="http://schema.org/NewsArticle">
<link itemprop="mainEntityOfPage" href="https://www.etfdailynews.com/2022/04/23/comparing-aea-bridges-impact-nyseimpx-arcimoto-nasdaqfuv/" />
<h1 itemprop="headline" class="page-title">Comparing AEA-Bridges Impact (NYSE:IMPX) &amp; Arcimoto (NASDAQ:FUV)</h1>
<p class="postmeta">
Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://www.etfdailynews.com/author/marketbeat/" title="Posts by MarketBeat News" rel="author">MarketBeat News</a></span></span> on <span itemprop="datePublished dateModified" content="2022-04-23T14:14:41+0000">Apr 23rd, 2022</span>
</p>
<div class="social-shares">
<a title="Share on Twitter" rel="noopener nofollow" target="_blank" style="background: #1DA1F2;" href="https://twitter.com/intent/tweet?original_referer=https%3A%2F%2Fwww.etfdailynews.com&ref_src=twsrc%5Etfw&text=Comparing%20AEA-Bridges%20Impact%20%28NYSE%3AIMPX%29%20%26amp%3B%20Arcimoto%20%28NASDAQ%3AFUV%29%20%24FUV&tw_p=tweetbutton&url=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F04%2F23%2Fcomparing-aea-bridges-impact-nyseimpx-arcimoto-nasdaqfuv%2F&via=etfdailynews"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z" /></svg></span><span class="share-title">Share on Twitter</span></a>
<a title="Share on Facebook" rel="noopener nofollow" target="_blank" style="background:#4267B2;" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F04%2F23%2Fcomparing-aea-bridges-impact-nyseimpx-arcimoto-nasdaqfuv%2F"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z" /></svg></span><span class="share-title">Share on Facebook</span></a>
<a title="Share on LinkedIn" rel="noopener nofollow" target="_blank" style="background: #0067b1;" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F04%2F23%2Fcomparing-aea-bridges-impact-nyseimpx-arcimoto-nasdaqfuv%2F"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z" /></svg></span><span class="share-title">Share on LinkedIn</span></a>
<a title="Share on Stocktwits" rel="noopener nofollow" style="background:#228dff;" href="https://api.stocktwits.com/widgets/share?via=MarketBeat&amp;body=Comparing%20AEA-Bridges%20Impact%20%28NYSE%3AIMPX%29%20%26amp%3B%20Arcimoto%20%28NASDAQ%3AFUV%29%20%24FUV" title="Share on StockTwits"><span class="share-button"><svg style="fill:#fff;" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="24" height="24" viewBox="0 0 30 30" style="enable-background:new 0 0 30 30;" xml:space="preserve"><polygon class="st0" points="21.98,17.75 21.98,13.29 14.54,9.67 21.98,6.19 21.98,1.84 9.02,8.45 9.02,11.12 " /><polygon class="st0" points="9.07,13.19 9.07,17.65 16.49,21.27 9.07,24.76 9.07,29.1 21.98,22.49 21.98,19.82 " /></svg></span><span class="share-title">Share on Stocktwits</span></a>
</div>
<div style="clear:both"></div>

<div class="entry" itemprop="articleBody">

<p>Arcimoto (<a href='https://www.marketbeat.com/stocks/NASDAQ/FUV/'>NASDAQ:FUV</a> &#8211; <a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=FUV&#038;lead_source=etfdailynews_snra&#038;utm_source=etfdailynews_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=FUV&#038;utm_content=text_link'>Get Rating</a>) and AEA-Bridges Impact (<a href='https://www.marketbeat.com/stocks/NYSE/IMPX/'>NYSE:IMPX</a> &#8211; <a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=IMPX&#038;lead_source=etfdailynews_snra&#038;utm_source=etfdailynews_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=IMPX&#038;utm_content=text_link'>Get Rating</a>) are both small-cap auto/tires/trucks companies, but which is the superior business? We will compare the two businesses based on the strength of their valuation, analyst recommendations, institutional ownership, profitability, risk, earnings and dividends. </p>
<p><strong style='text-decoration:underline'>Analyst Ratings</strong></p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
<input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-ETF Daily News" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:FUV" /> <label for="InPostRegistrationEmail">Get <b>Arcimoto</b> alerts:</label>
<div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 0.9em;line-height: 1em;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" class="button" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;font-size: 0.9em;font-weight: 700;line-height: 1em;padding: 6px 18px"></div>
</form>
<div id="ShowSuggestionInPost"></div>
<p>This is a summary of current ratings and price targets for Arcimoto and AEA-Bridges Impact, as reported by MarketBeat. </p>
<div class='comparisontable-wrapper'>
<table class='comparisontable'>
<tr>
<td></td>
<td><strong>Sell Ratings</td>
<td><strong>Hold Ratings</td>
<td><strong>Buy Ratings</td>
<td><strong>Strong Buy Ratings</td>
<td><strong>Rating Score</strong></td>
</tr>
<tr>
<td><strong>Arcimoto</strong></td>
<td>0</td>
<td>2</td>
<td>2</td>
<td>0</td>
<td>2.50</td>
</tr>
<tr>
<td><strong>AEA-Bridges Impact</strong></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>N/A</td>
</tr>
</table>
</div>
<p>
<div class="in-article-ad" class="width:340px;">


<div id='div-gpt-ad-1646836411098-0' style='min-width: 336px; min-height: 280px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1646836411098-0'); });
  </script>
</div>
</div>
Arcimoto currently has a consensus target price of $18.00, suggesting a potential upside of 359.18%. Given Arcimoto&#8217;s higher possible upside, equities analysts plainly believe Arcimoto is more favorable than AEA-Bridges Impact.</p>
<p><strong style='text-decoration:underline'>Volatility &amp; Risk</strong></p>
<p>Arcimoto has a beta of 2.37, meaning that its stock price is 137% more volatile than the S&#038;P 500. Comparatively, AEA-Bridges Impact has a beta of -0.09, meaning that its stock price is 109% less volatile than the S&#038;P 500. </p>
<p><strong style='text-decoration:underline'>Valuation &amp; Earnings</strong></p>
<p>This table compares Arcimoto and AEA-Bridges Impact&#8217;s revenue, earnings per share (EPS) and valuation.</p>
<div class='comparisontable-wrapper'>
<table class='comparisontable'>
<tr>
<td></td>
<td><strong>Gross Revenue</strong></td>
<td><strong>Price/Sales Ratio</strong></td>
<td><strong>Net Income</strong></td>
<td><strong>Earnings Per Share</strong></td>
<td><strong>Price/Earnings Ratio</strong></td>
</tr>
<tr>
<td><strong>Arcimoto</strong></td>
<td>$4.39 million</td>
<td>34.13</td>
<td>-$47.56 million</td>
<td>($1.30)</td>
<td>-3.02</td>
</tr>
<tr>
<td><strong>AEA-Bridges Impact</strong></td>
<td>N/A</td>
<td>N/A</td>
<td>$4.82 million</td>
<td>N/A</td>
<td>N/A</td>
</tr>
</table>
</div>
<p>AEA-Bridges Impact has lower revenue, but higher earnings than Arcimoto. </p>
<p><strong style='text-decoration:underline'>Profitability</strong></p>
<p>This table compares Arcimoto and AEA-Bridges Impact&#8217;s net margins, return on equity and return on assets.</p>
<div class='comparisontable-wrapper'>
<table class='comparisontable'>
<tr>
<td></td>
<td><strong>Net Margins</strong></td>
<td><strong>Return on Equity</strong></td>
<td><strong>Return on Assets</strong></td>
</tr>
<tr>
<td><strong>Arcimoto</strong></td>
<td>-996.96%</td>
<td>-68.12%</td>
<td>-60.78%</td>
</tr>
<tr>
<td><strong>AEA-Bridges Impact</strong></td>
<td>N/A</td>
<td>-24.88%</td>
<td>1.20%</td>
</tr>
</table>
</div>
<p><strong style='text-decoration:underline'>Insider &amp; Institutional Ownership</strong></p>
<p>23.4% of Arcimoto shares are held by institutional investors. Comparatively, 82.8% of AEA-Bridges Impact shares are held by institutional investors. 23.6% of Arcimoto shares are held by company insiders. Strong institutional ownership is an indication that hedge funds, large money managers and endowments believe a company is poised for long-term growth.</p>
<p><strong style='text-decoration:underline'>Arcimoto Company Profile</strong> (<a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=FUV&#038;lead_source=etfdailynews_snra&#038;utm_source=etfdailynews_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=FUV&#038;utm_content=text_link'>Get Rating</a>)</p>
<p><img height="150" width="250" src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&h=150&zc=2&src=https://www.marketbeat.com/logos/arcimoto-inc-logo.PNG?v=20210122143746" alt="Arcimoto logo" title="Arcimoto" class="companylogo" />Arcimoto, Inc. designs, develops, manufactures, sells, and rents three-wheeled electric vehicles in the United States. Its flagship product is the Fun Utility Vehicle (FUV) use for everyday consumer trips. The company also provides Rapid Responder designed to perform emergency, security, and law enforcement services; Deliverator, an electric last-mile delivery solution to get goods where they need to go; Cameo, an FUV equipped with a rear-facing rear seat and a modified roof built for on-road filming; and Arcimoto Roadster, an unparalleled pure-electric on-road thrill machine. In addition, it offers TRiO, a bolt on kit that converts a two wheeled motorcycle into a tilting three wheeled motorcycle. The company was formerly known as WTP Incorporated and changed its name to Arcimoto, Inc. in December 2011. Arcimoto, Inc. was incorporated in 2007 and is headquartered in Eugene, Oregon.</p>
<p><strong style='text-decoration:underline'>AEA-Bridges Impact Company Profile</strong> (<a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=IMPX&#038;lead_source=etfdailynews_snra&#038;utm_source=etfdailynews_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=IMPX&#038;utm_content=text_link'>Get Rating</a>)</p>
<p><img height="150" width="250" src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&h=150&zc=2&src=https://www.marketbeat.com/logos/aea-bridges-impact-corp-logo.png?v=20211213081102" alt="AEA-Bridges Impact logo" title="AEA-Bridges Impact" class="companylogo" />AEA-Bridges Impact Corp. does not have significant operations. It intends to effect a merger, amalgamation, share exchange, asset acquisition, share purchase, reorganization, or similar business combination with one or more businesses. The company was incorporated in 2020 and is based in Grand Cayman, Cayman Islands.</p>
<p></p>
<p><strong>Want More Great Investing Ideas?</strong></p>
<ul>
<li><a href="https://report.stocknews.com/free-report/3stocks/?formplacement=artbottom3s_etf" target="_blank"><span style="color:#d32f2f;">3 Stocks to DOUBLE This Year</span></a></li>
<li><a href="https://www.marketbeat.com/newsletter/PDFoffer.aspx?offer=newyear&RegistrationCode=ETFDailyNews" target="_blank"><span style="color:#d32f2f;">The 10 Best Stocks to Own in 2022</span></a></li>
<li><a href="https://www.marketbeat.com/newsletter/PDFoffer.aspx?offer=buyandhold&RegistrationCode=ETFDailyNews" target="_blank"><span style="color:#d32f2f;">7 Stocks to Buy and Hold Forever</span></a></li>
<li><a href="https://report.stocknews.com/9-must-have-stocks/?formplacement=artbottom9g_etf" target="_blank"><span style="color:#d32f2f;">9 "MUST OWN" Growth Stocks</span></a></li>
</ul>





<p style="clear:both"><strong>Receive News &amp; Ratings for Arcimoto Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Arcimoto and related companies with <a href="/daily-email-updates-basic/?symbol=NASDAQ:FUV&c=Arcimoto" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" aria-label="Your Email Address" class="signup" />
<input type="hidden" id="Hidden3" name="RegistrationCode" value="ETF Daily News-Footer" />
<input type="hidden" id="Hidden4" name="RegisterTicker" value="NASDAQ:FUV" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>

</div> 


<div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=500&h=300&zc=2&src=https://www.marketbeat.com/logos/aea-bridges-impact-corp-logo.png?v=20211213081102" />
<meta itemprop="width" content="500">
<meta itemprop="height" content="300">
</div>
<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo-02.png">
<meta itemprop="width" content="550">
<meta itemprop="height" content="188">
</div>
<meta itemprop="name" content="ETF Daily News" />
<meta itemprop="url" content="https://etfdailynews.com" />
</div>

</article>

<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx" title="More Headlines"></iframe>


<nav id="prevnext">
<a href="https://www.etfdailynews.com/2022/04/23/baytex-energy-bte-to-release-earnings-on-thursday/" rel="prev"><div class="previous"><h2 class="h4">&laquo; PREVIOUS HEADLINE</h2><p>Baytex Energy (BTE) to Release Earnings on Thursday</p></div></a> <a href="https://www.etfdailynews.com/2022/04/23/0-08-eps-expected-for-growgeneration-corp-nasdaqgrwg-this-quarter/" rel="next"><div class="next"><h2 class="h4">NEXT HEADLINE &raquo;</h2><p>-$0.08 EPS Expected for GrowGeneration Corp. (NASDAQ:GRWG) This Quarter</p></div></a>
</nav>
<div id="latest-news">
<h2>You might be interested in:</h2>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/marinemax-inc-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="MarineMax  Set to Announce Quarterly Earnings on Thursday" />
</div></div>

<a href="https://www.etfdailynews.com/2022/04/23/marinemax-hzo-set-to-announce-quarterly-earnings-on-thursday/" rel="bookmark">MarineMax Set to Announce Quarterly Earnings on Thursday</a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/twin-disc-inc-logo.gif&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Twin Disc  Set to Announce Quarterly Earnings on Friday" />
</div></div>

<a href="https://www.etfdailynews.com/2022/04/23/twin-disc-twin-set-to-announce-quarterly-earnings-on-friday/" rel="bookmark">Twin Disc Set to Announce Quarterly Earnings on Friday</a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/amarin-co-plc-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Amarin Co. plc  Expected to Post Earnings of -$0.02 Per Share" />
</div></div>

<a href="https://www.etfdailynews.com/2022/04/23/amarin-co-plc-nasdaqamrn-expected-to-post-earnings-of-0-02-per-share/" rel="bookmark">Amarin Co. plc Expected to Post Earnings of -$0.02 Per Share</a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/passur-aerospace-inc-logo.png&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Head to Head Survey: NextNav  and PASSUR Aerospace " />
</div></div>

<a href="https://www.etfdailynews.com/2022/04/23/head-to-head-survey-nextnav-nasdaqnn-and-passur-aerospace-otcmktspssr/" rel="bookmark">Head to Head Survey: NextNav and PASSUR Aerospace </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/advantage-solutions-inc-logo.png&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Zacks: Analysts Expect Advantage Solutions Inc.  Will Announce Earnings of $0.13 Per Share" />
</div></div>

<a href="https://www.etfdailynews.com/2022/04/23/zacks-analysts-expect-advantage-solutions-inc-nasdaqadv-will-announce-earnings-of-0-13-per-share/" rel="bookmark">Zacks: Analysts Expect Advantage Solutions Inc. Will Announce Earnings of $0.13 Per Share</a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/nektar-therapeutics-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Nektar Therapeutics  Expected to Post Earnings of -$0.79 Per Share" />
</div></div>

<a href="https://www.etfdailynews.com/2022/04/23/nektar-therapeutics-nasdaqnktr-expected-to-post-earnings-of-0-79-per-share/" rel="bookmark">Nektar Therapeutics Expected to Post Earnings of -$0.79 Per Share</a>
</div>
</div>

<br>
</main> 
<aside class="flex-sidebar">
<div class="flex-container">
<div class="sidebar-section">
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx" width="336" height="600" frameborder="no" title="More Articles"></iframe>

</div>
<div class="sidebar-section">


<div class="sidebar-email">
<h3>Daily Ratings &amp; News for Arcimoto</h3>
Complete the form below to receive the latest headlines and analysts' recommendations for Arcimoto with our free daily email newsletter:<br />
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="RegisterEmailSidebar" style='width:100%' name="RegisterEmail" type="email" placeholder="Your Email Address" aria-label="Your Email Address">
<input type="hidden" id="Hidden7" name="RegistrationCode" value="ETF Daily News-Sidebar">
<input type="hidden" id="Hidden8" name="RegisterTicker" value="NASDAQ:FUV" /> <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:100%;height:30px">
<div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
</form>
</div>


<br>
<a style="background: #075A8D;color: #fff;padding: 5px 7px 4px;border-radius: 3px;font-size: 12px;text-decoration: none;" href="https://twitter.com/intent/follow?original_referer=https%3A%2F%2Fwww.etfdailynews.com%2F&ref_src=twsrc%5Etfw&screen_name=etfdailynews" target="_blank" rel="noopener nofollow">
<svg style="width: 13px;vertical-align: middle;margin-right: 4px;fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z" /></svg> Follow @etfdailynews</a>



<br />
<div>
<h3>Recent News</h3>
<ul>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/marinemax-hzo-set-to-announce-quarterly-earnings-on-thursday/">MarineMax (HZO) Set to Announce Quarterly Earnings on Thursday</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/twin-disc-twin-set-to-announce-quarterly-earnings-on-friday/">Twin Disc (TWIN) Set to Announce Quarterly Earnings on Friday</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/amarin-co-plc-nasdaqamrn-expected-to-post-earnings-of-0-02-per-share/">Amarin Co. plc (NASDAQ:AMRN) Expected to Post Earnings of -$0.02 Per Share</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/head-to-head-survey-nextnav-nasdaqnn-and-passur-aerospace-otcmktspssr/">Head to Head Survey: NextNav (NASDAQ:NN) and PASSUR Aerospace (OTCMKTS:PSSR)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/zacks-analysts-expect-advantage-solutions-inc-nasdaqadv-will-announce-earnings-of-0-13-per-share/">Zacks: Analysts Expect Advantage Solutions Inc. (NASDAQ:ADV) Will Announce Earnings of $0.13 Per Share</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/nektar-therapeutics-nasdaqnktr-expected-to-post-earnings-of-0-79-per-share/">Nektar Therapeutics (NASDAQ:NKTR) Expected to Post Earnings of -$0.79 Per Share</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/analysts-anticipate-root-inc-nasdaqroot-to-announce-0-42-earnings-per-share/">Analysts Anticipate Root, Inc. (NASDAQ:ROOT) to Announce -$0.42 Earnings Per Share</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/0-39-earnings-per-share-expected-for-prophase-labs-inc-nasdaqprph-this-quarter/">$0.39 Earnings Per Share Expected for ProPhase Labs, Inc. (NASDAQ:PRPH) This Quarter</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/0-11-eps-expected-for-casella-waste-systems-inc-nasdaqcwst-this-quarter/">$0.11 EPS Expected for Casella Waste Systems, Inc. (NASDAQ:CWST) This Quarter</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/financial-contrast-bowlero-nysebowl-live-nation-entertainment-nyselyv/">Financial Contrast: Bowlero (NYSE:BOWL) &amp; Live Nation Entertainment (NYSE:LYV)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/0-08-eps-expected-for-growgeneration-corp-nasdaqgrwg-this-quarter/">-$0.08 EPS Expected for GrowGeneration Corp. (NASDAQ:GRWG) This Quarter</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/comparing-aea-bridges-impact-nyseimpx-arcimoto-nasdaqfuv/">Comparing AEA-Bridges Impact (NYSE:IMPX) &amp; Arcimoto (NASDAQ:FUV)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/contrasting-invitation-homes-nyseinvh-and-tricon-residential-nysetcn/">Contrasting Invitation Homes (NYSE:INVH) and Tricon Residential (NYSE:TCN)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/1-16-earnings-per-share-expected-for-azul-s-a-nyseazul-this-quarter/">-$1.16 Earnings Per Share Expected for Azul S.A. (NYSE:AZUL) This Quarter</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/koppers-holdings-inc-nysekop-expected-to-announce-earnings-of-0-84-per-share/">Koppers Holdings Inc. (NYSE:KOP) Expected to Announce Earnings of $0.84 Per Share</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/comparing-granite-point-mortgage-trust-nysegpmt-kilroy-realty-nysekrc/">Comparing Granite Point Mortgage Trust (NYSE:GPMT) &amp; Kilroy Realty (NYSE:KRC)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/seanergy-maritime-holdings-corp-nasdaqship-expected-to-post-earnings-of-0-04-per-share/">Seanergy Maritime Holdings Corp. (NASDAQ:SHIP) Expected to Post Earnings of $0.04 Per Share</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/baytex-energy-bte-to-release-earnings-on-thursday/">Baytex Energy (BTE) to Release Earnings on Thursday</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/wipro-wit-scheduled-to-post-earnings-on-friday/">Wipro (WIT) Scheduled to Post Earnings on Friday</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/04/23/st-joe-joe-set-to-announce-quarterly-earnings-on-wednesday/">St. Joe (JOE) Set to Announce Quarterly Earnings on Wednesday</a></li>
</ul>
</div>
</div>
</div>

</aside>
<div style="clear: both;"></div>
</div> 
<footer class="full-width">
<div class="width-limiter flex-container">
<div id="footer-info" class="add-padding flex-nav">
</div>
<span id="copyright" class="add-padding flex-copyright">
&copy; 2018-2022 <a href="https://www.etfdailynews.com">ETF Daily News</a>
</span>
</div>

<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/standalone/viewcount.ashx?ArticleHistoryID=88149096&PostDate=2022-4-23&type=p&id=564463&domain=www.etfdailynews.com&referrer=' + encodeURIComponent(document.referrer) + '" alt="" width="1" height="1" style="float:left;" />');</script>

</footer>
</div>

<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1" alt=""></noscript>


<script type="text/javascript">
var sc_project=12682890; 
var sc_invisible=1; 
var sc_security="f2745ebe"; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/12682890/0/f2745ebe/1/" height="1" width="1"  alt=""></noscript>

</body>
</html>
