<!doctype html>
<html lang="en">
<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="google-site-verification" content="swFzT9uWAz-P-dtjcCuwxp3R6yIBLsXkeqbwG3n9x_o" />
<meta name="theme-color" content="#b71c32" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">

<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script>
<link rel="preconnect" href="https://fonts.gstatic.com">
<link href="https://fonts.googleapis.com/css2?family=Copse&family=Lato&display=swap" rel="stylesheet">
<style>

:root {
  --header-background: #ffffff;
  --button-background: #b71c32;
  --button-background-2: #88021d;
  --button-hover-background: #b71c32;
  --button-hover-background-2: #b71c32;
  --button-text-color: #fff;
  --link-color: #257192;
  --link-hover-color: #288aa3;
  --link-text-decoration: none; /* text field */
  --hover-link-text-decoration: underline; /* text field */
  --menu-background: #111111;
  --menu-background-2: #111111;
  --menu-text-color: #fff;
  --menu-active-hover-background: #257192;
  --menu-active-hover-text-color: #fff;
  --top-menu-background: #eff2f4;
  --top-menu-link-color: #257192;
  --top-menu-link-hover-color: #164f5d;
  --accent-color: #257192;
  --accent-color-2: #257192;
  --sidebar-h3-color: #257192;
  --light-gray-color:#eff2f4;
  --light-gray-link-color:#eff2f4;
  --light-gray-link-hover-color:#eff2f4;
  --list-item-bottom-border: solid 1px #eff2f4;
  --border-radius: 3px;
  --border-radius-small-items: 1px;
  --H1-font: 2.1em/1.3 "Copse",serif;
  --H2-font:  1.4em/1.3 "Copse",serif;
  --H3-font:  bold uppercase 1.1em/1.3 "Lato",sans-serif;
  --body-font: 15px "Lato",sans-serif;
  --menu-font: 1em "Lato", sans-serif;
  --box-shadow: 0px 0px 1px 0px #eff2f4; 
  --body-background: #257192;
  --body-background-2: #111111;
  --body-font-color: #111111;

}


body {
	font: var(--body-font);
    background: var(--body-background);
	color: var(--body-font-color);
	 
		
	background: -moz-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -webkit-gradient(left top,left bottom,color-stop(0%, var(--body-background)),color-stop(100%, var(--body-background-2)));
    background: -webkit-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -o-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -ms-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: linear-gradient(to bottom, var(--body-background) 0%, var(--body-background-2) 100%);
		
    background-attachment: fixed;
    background-size: cover;
}

</style>
<link rel="stylesheet" href="https://www.etfdailynews.com/wp-content/themes/responsalambre/style.css?v=2021abcdefghij" type="text/css" media="screen">
<link href="https://www.etfdailynews.com/feed/" rel="alternate" title="ETF Daily News RSS Feed" type="application/rss+xml" />
<link href="https://www.etfdailynews.com/feed/atom/" rel="alternate" title="ETF Daily News Atom Feed" type="application/atom+xml" />
<link href="https://www.etfdailynews.com/xmlrpc.php" rel="pingback" />
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-group-css' href='https://www.etfdailynews.com/wp-content/plugins/bwp-minify/min/?f=wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://www.etfdailynews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.etfdailynews.com/wp-json/wp/v2/posts/945483" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.etfdailynews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.etfdailynews.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0.2" />
<link rel="canonical" href="https://www.etfdailynews.com/2022/09/28/allworth-financial-lp-has-63000-position-in-paccar-inc-nasdaqpcar/" />
<link rel='shortlink' href='https://www.etfdailynews.com/?p=945483' />
<link rel="alternate" type="application/json+oembed" href="https://www.etfdailynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F09%2F28%2Fallworth-financial-lp-has-63000-position-in-paccar-inc-nasdaqpcar%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.etfdailynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F09%2F28%2Fallworth-financial-lp-has-63000-position-in-paccar-inc-nasdaqpcar%2F&#038;format=xml" />
<link rel="manifest" href="https://www.etfdailynews.com/manifest.json"><link rel="amphtml" href="https://www.etfdailynews.com/2022/09/28/allworth-financial-lp-has-63000-position-in-paccar-inc-nasdaqpcar/amp/" /><link rel="icon" href="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo_etf-icon-1-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo_etf-icon-1-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo_etf-icon-1-300x300.png" />
<meta name="msapplication-TileImage" content="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo_etf-icon-1-300x300.png" />

<title>Allworth Financial LP Has $63,000 Position in PACCAR Inc (NASDAQ:PCAR) - ETF Daily News</title>
<meta name="description" content="Read Allworth Financial LP Has $63,000 Position in PACCAR Inc (NASDAQ:PCAR) at ETF Daily News" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="description" content="Allworth Financial LP increased its position in PACCAR Inc (NASDAQ:PCAR &#8211; Get Rating) by 42.0% in the 2nd quarter, according to its most recent disclosure with the Securities and Exchange Commission (SEC). The firm owned 761 shares of the company&#8217;s stock after buying an additional 225 shares during the quarter. Allworth Financial LP&#8217;s holdings in [&hellip;]" />
<meta name="author" content="MarketBeat News">
<meta name="news_keywords" content="PACCAR,NASDAQ:PCAR,PCAR,Auto/Tires/Truck,69371810,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="keywords" content="PACCAR,NASDAQ:PCAR,PCAR,Auto/Tires/Truck,69371810,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="ticker" content="NASDAQ:PCAR" />
<meta name="contentType" content="article">

<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@MarketBeatCom" />
<meta name="twitter:title" content="Allworth Financial LP Has $63,000 Position in PACCAR Inc (NASDAQ:PCAR)" />
<meta name="twitter:description" content="Allworth Financial LP increased its position in PACCAR Inc (NASDAQ:PCAR &#8211; Get Rating) by 42.0% in the 2nd quarter, according to its most recent disclosure with the Securities and Exchange Commission (SEC). The firm owned 761 shares of the company&#8217;s stock after buying an additional 225 shares during the quarter. Allworth Financial LP&#8217;s holdings in [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/paccar-logo.jpg&amp;w=240&amp;h=240&amp;zc=2" />

<meta property="og:title" content="Allworth Financial LP Has $63,000 Position in PACCAR Inc (NASDAQ:PCAR)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.etfdailynews.com/2022/09/28/allworth-financial-lp-has-63000-position-in-paccar-inc-nasdaqpcar/" />
<meta property="og:image" content="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/paccar-logo.jpg&amp;w=240&amp;h=240&amp;zc=2" />
<meta property="og:image:width" content="240" />
<meta property="og:image:height" content="240" />
<meta property="og:description" content="Allworth Financial LP increased its position in PACCAR Inc (NASDAQ:PCAR &#8211; Get Rating) by 42.0% in the 2nd quarter, according to its most recent disclosure with the Securities and Exchange Commission (SEC). The firm owned 761 shares of the company&#8217;s stock after buying an additional 225 shares during the quarter. Allworth Financial LP&#8217;s holdings in [&hellip;]" />
<meta property="og:site_name" content="ETF Daily News" />
<meta property="og:locale" content="en_US" />

<meta property="article:published_time" content="2022-09-28T10:12:44+0000" />
<meta property="article:modified_time" content="2022-09-28T10:12:44+0000" />
<meta property="article:tag" content="NASDAQ:PCAR" />
<meta property="article:tag" content="PACCAR,NASDAQ:PCAR,PCAR,Auto/Tires/Truck,69371810,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta property="article:section" content="Markets" />


<script type='text/javascript'>var PopupAdChannel=''; </script>
<link rel="manifest" href="/manifest.json">
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
<script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'etfdailynews.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "cca79df0-f0c0-4b3f-906c-d1d378701b61",
      safari_web_id: '', 
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}  </script>
<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>
<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=2021"></script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {

	var responsiveAdSlot = googletag.defineSlot('/21771534901/ETF',[[728, 90], [300, 250]], 'div-gpt-ad-1663600271841-0').addService(googletag.pubads());
	var mapping = googletag.sizeMapping().addSize([1024, 0], [[728, 90]]).addSize([0, 0], [300, 250]).build();
	responsiveAdSlot.defineSizeMapping(mapping);
	googletag.pubads().enableSingleRequest();
	googletag.enableServices();

  });

</script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21771534901/ETF', [300, 250], 'div-gpt-ad-1646836411098-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-8025563-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-8025563-1');
</script>
<script src="https://ef53b36683c44880ae01202dedb7e921.js.ubembed.com" async></script>
</head>
<body>
<div id="wrap">

<a class="skip-link scroll" href="#main">Skip to main content</a>
<header>
<div class="width-limiter background-light top-menu-bar">
<div style='color:#222;text-align:right;'>
</div>
</div>

<div class="width-limiter top-mobile-menu" id='mobile-logo-bar'>
<label for="nav-trigger" style="display:inline-block; width:30vw; color:#12424d;vertical-align:middle;">&#9776;</label>
<a style='vertical-align:middle;width:33vw;display:inline-block;text-align:center;padding:5px;' href="https://www.etfdailynews.com"><img style='width:120px' src="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo-02.png" alt="ETF Daily News logo" width="550" height="188"></a>
</div>
<div class="width-limiter" style="min-height: 5px;" id='mobile-menu-bar'>
<input type="checkbox" id="nav-trigger" class="navOpen" />
<div class="mobile-nav nice-scroll">
<nav class="mobile-menu" aria-label="Category Mobile Menu"><ul id="menu-main-menu" class="menu"><li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://www.etfdailynews.com/category/markets/analyst-articles-us/">Analyst Ratings</a></li>
<li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.etfdailynews.com/category/markets/cryptocurrencies/">Crypto</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://www.etfdailynews.com/category/markets/earnings-articles-single/">Earnings</a></li>
<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://www.etfdailynews.com/category/markets/insider-trades/">Insider Trades</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://www.etfdailynews.com/category/markets/ipo-articles/">IPOs</a></li>
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://www.etfdailynews.com/category/markets/options-articles/">Options</a></li>
</ul></nav>
<form class="mobile-search" id="mobileSearchForm" action="https://www.etfdailynews.com/" method="get">
<div class="search">
<input id="s" style='margin-left:0;' class="searchinput" aria-label="Search Keywords" name="s" onclick="this.value='';" type="text" />
<input class="searchsubmit" type="submit" value="SEARCH" />
</div>
</form>
<div>
</div>
</div>
</div>

<div class="width-limiter add-padding flex-container">
<a class="logo-link flex-logo" id="header-logo-link" href="https://www.etfdailynews.com" title="ETF Daily News"><img id="logo" src="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo-02.png" alt="ETF Daily News logo" width="550" height="188"></a>

<div id="AlternateHeaderUnit" class="flex-header-ad">

<div id='div-gpt-ad-1663600271841-0' style='min-width: 300px; min-height: 90px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1663600271841-0'); });
  </script>
</div>
</div>

</div> 
<div id="menu">
<div class="width-limiter flex-container" id="nav-main">

<div class="flex-nav">
<nav class="navigation" aria-label="Main Menu"><ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://www.etfdailynews.com/category/markets/analyst-articles-us/">Analyst Ratings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.etfdailynews.com/category/markets/cryptocurrencies/">Crypto</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://www.etfdailynews.com/category/markets/earnings-articles-single/">Earnings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://www.etfdailynews.com/category/markets/insider-trades/">Insider Trades</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://www.etfdailynews.com/category/markets/ipo-articles/">IPOs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://www.etfdailynews.com/category/markets/options-articles/">Options</a></li>
</ul></nav>
</div>
<form class="flex-search" id="searchform" action="https://www.etfdailynews.com/" method="get">
<div class="search">
<input id="s-main" class="searchinput" name="s" aria-label="Search Keywords" onclick="this.value='';" type="text" />
<input class="searchsubmit" type="submit" value="SEARCH" />
</div>
</form>
</div> 
</div> 
</header> 
<div class="width-limiter main-content flex-container">
<main class="flex-main" id="main">
<article itemscope itemtype="http://schema.org/NewsArticle">
<link itemprop="mainEntityOfPage" href="https://www.etfdailynews.com/2022/09/28/allworth-financial-lp-has-63000-position-in-paccar-inc-nasdaqpcar/" />
<h1 itemprop="headline" class="page-title">Allworth Financial LP Has $63,000 Position in PACCAR Inc (NASDAQ:PCAR)</h1>
<p class="postmeta">
Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://www.etfdailynews.com/author/marketbeat/" title="Posts by MarketBeat News" rel="author">MarketBeat News</a></span></span> on <span itemprop="datePublished dateModified" content="2022-09-28T10:12:44+0000">Sep 28th, 2022</span>
</p>
<div class="social-shares">
<a title="Share on Twitter" rel="noopener nofollow" target="_blank" style="background: #1DA1F2;" href="https://twitter.com/intent/tweet?original_referer=https%3A%2F%2Fwww.etfdailynews.com&ref_src=twsrc%5Etfw&text=Allworth%20Financial%20LP%20Has%20%2463%2C000%20Position%20in%20PACCAR%20Inc%20%28NASDAQ%3APCAR%29%20%24PCAR&tw_p=tweetbutton&url=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F09%2F28%2Fallworth-financial-lp-has-63000-position-in-paccar-inc-nasdaqpcar%2F&via=etfdailynews"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z" /></svg></span><span class="share-title">Share on Twitter</span></a>
<a title="Share on Facebook" rel="noopener nofollow" target="_blank" style="background:#4267B2;" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F09%2F28%2Fallworth-financial-lp-has-63000-position-in-paccar-inc-nasdaqpcar%2F"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z" /></svg></span><span class="share-title">Share on Facebook</span></a>
<a title="Share on LinkedIn" rel="noopener nofollow" target="_blank" style="background: #0067b1;" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F09%2F28%2Fallworth-financial-lp-has-63000-position-in-paccar-inc-nasdaqpcar%2F"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z" /></svg></span><span class="share-title">Share on LinkedIn</span></a>
<a title="Share on Stocktwits" rel="noopener nofollow" style="background:#228dff;" href="https://api.stocktwits.com/widgets/share?via=MarketBeat&amp;body=Allworth%20Financial%20LP%20Has%20%2463%2C000%20Position%20in%20PACCAR%20Inc%20%28NASDAQ%3APCAR%29%20%24PCAR" title="Share on StockTwits"><span class="share-button"><svg style="fill:#fff;" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="24" height="24" viewBox="0 0 30 30" style="enable-background:new 0 0 30 30;" xml:space="preserve"><polygon class="st0" points="21.98,17.75 21.98,13.29 14.54,9.67 21.98,6.19 21.98,1.84 9.02,8.45 9.02,11.12 " /><polygon class="st0" points="9.07,13.19 9.07,17.65 16.49,21.27 9.07,24.76 9.07,29.1 21.98,22.49 21.98,19.82 " /></svg></span><span class="share-title">Share on Stocktwits</span></a>
</div>
<div style="clear:both"></div>

<div class="entry" itemprop="articleBody">

<p><img height="150" width="250" src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&h=150&zc=2&src=https://www.marketbeat.com/logos/paccar-logo.jpg" alt="PACCAR logo" title="PACCAR" class="companylogo" />Allworth Financial LP increased its position in PACCAR Inc (<a href="https://www.marketbeat.com/stocks/NASDAQ/PCAR/">NASDAQ:PCAR</a> &#8211; <a style="font-weight:normal;text-decoration:italic;color:green" href="https://report.stocknews.com/sign-up/ticker/?ticker=PCAR&#038;lead_source=etfdailynews_snra&#038;utm_source=etfdailynews_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=PCAR&#038;utm_content=text_link">Get Rating</a>) by 42.0% in the 2nd quarter, according to its most recent disclosure with the Securities and Exchange Commission (SEC). The firm owned 761 shares of the company&#8217;s stock after buying an additional 225 shares during the quarter. Allworth Financial LP&#8217;s holdings in PACCAR were worth $63,000 as of its most recent filing with the Securities and Exchange Commission (SEC). </p>
<p>Several other institutional investors and hedge funds also recently made changes to their positions in the company. Norges Bank acquired a new stake in PACCAR during the 4th quarter valued at approximately $287,028,000. Wellington Management Group LLP increased its position in PACCAR by 249.2% during the 1st quarter. Wellington Management Group LLP now owns 3,845,387 shares of the company&#8217;s stock valued at $338,663,000 after purchasing an additional 2,744,040 shares during the period. Massachusetts Financial Services Co. MA increased its position in PACCAR by 17.5% during the 1st quarter. Massachusetts Financial Services Co. MA now owns 8,980,211 shares of the company&#8217;s stock valued at $790,887,000 after purchasing an additional 1,334,765 shares during the period. Prudential Financial Inc. increased its position in PACCAR by 383.6% during the 1st quarter. Prudential Financial Inc. now owns 1,555,223 shares of the company&#8217;s stock valued at $136,968,000 after purchasing an additional 1,233,650 shares during the period. Finally, JPMorgan Chase &#038; Co. increased its position in PACCAR by 113.1% during the 1st quarter. JPMorgan Chase &#038; Co. now owns 1,931,741 shares of the company&#8217;s stock valued at $170,130,000 after purchasing an additional 1,025,284 shares during the period. Institutional investors and hedge funds own 64.17% of the company&#8217;s stock. </p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
<input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-ETF Daily News" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:PCAR" /> <label for="InPostRegistrationEmail">Get <b>PACCAR</b> alerts:</label>
<div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 0.9em;line-height: 1em;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" class="button" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;font-size: 0.9em;font-weight: 700;line-height: 1em;padding: 6px 18px"></div>
</form>
<div id="ShowSuggestionInPost"></div>
<h2>Wall Street Analysts Forecast Growth</h2>
<p>A number of analysts have weighed in on PCAR shares. Credit Suisse Group increased their target price on shares of PACCAR from $102.00 to $104.00 and gave the company an &#8220;outperform&#8221; rating in a research report on Wednesday, July 27th. Citigroup increased their target price on shares of PACCAR from $88.00 to $90.00 and gave the company an &#8220;outperform&#8221; rating in a research report on Wednesday, July 27th. Cowen reduced their price objective on shares of PACCAR from $100.00 to $92.00 in a research report on Thursday, July 7th. Deutsche Bank Aktiengesellschaft raised their price objective on shares of PACCAR from $94.00 to $97.00 in a research report on Wednesday, July 27th. Finally, Cowen reduced their price objective on shares of PACCAR from $100.00 to $92.00 in a research report on Thursday, July 7th. One research analyst has rated the stock with a sell rating, five have assigned a hold rating, six have assigned a buy rating and one has given a strong buy rating to the stock. Based on data from MarketBeat, the company presently has an average rating of &#8220;Moderate Buy&#8221; and an average target price of $95.21.</p>
<h2>Insider Buying and Selling at PACCAR</h2>
<p>
<div class="in-article-ad">

<div id='div-gpt-ad-1646836411098-0' style='min-width: 305px; min-height: 250px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1646836411098-0'); });
  </script>
</div>
<div style="padding-top:1em;">
<strong>Want More Great Investing Ideas?</strong>
<ul>
<li><a href="https://report.stocknews.com/rtrsignup/?formplacement=artbottomrtr_etf" target="_blank"><span style="color:#d32f2f;">Bear Market Game Plan!</span></a></li>
<li><a href="https://www.marketbeat.com/newsletter/PDFoffer.aspx?offer=newyear&RegistrationCode=ETFDailyNews" target="_blank"><span style="color:#d32f2f;">The 10 Best Stocks to Own in 2022</span></a></li>
<li><a href="https://www.marketbeat.com/newsletter/PDFoffer.aspx?offer=buyandhold&RegistrationCode=ETFDailyNews" target="_blank"><span style="color:#d32f2f;">7 Stocks to Buy and Hold Forever</span></a></li>
<li><a href="https://report.stocknews.com/free-report/3stocks/?formplacement=artbottom3s_etf" target="_blank"><span style="color:#d32f2f;">3 Stocks to DOUBLE This Year</span></a></li>
</ul>
</div>
</div>
In other PACCAR news, VP <a target='_blank' rel="noopener" href='https://www.insidertrades.com/paccar-inc-stock/todd-r-hubbard/'>Todd R. Hubbard</a> sold 2,000 shares of the firm&#8217;s stock in a transaction on Friday, July 29th. The stock was sold at an average price of $91.50, for a total transaction of $183,000.00. Following the transaction, the vice president now directly owns 2,119 shares in the company, valued at approximately $193,888.50. The sale was disclosed in a document filed with the SEC, which is available through <a href='http://www.sec.gov/Archives/edgar/data/75362/000122520822009103/xslF345X03/doc4.xml' target='_blank' rel="noopener">this hyperlink</a>. Company insiders own 2.05% of the company&#8217;s stock. </p>
<h2>PACCAR Price Performance</h2>
<p>Shares of <a href='https://www.marketbeat.com/stocks/NASDAQ/PCAR/sec-filings/' target='_blank' rel="noopener">PCAR</a> opened at $82.96 on Wednesday. PACCAR Inc has a 12-month low of $77.00 and a 12-month high of $97.56. The business&#8217;s fifty day moving average is $88.83 and its 200 day moving average is $86.15. The company has a quick ratio of 2.36, a current ratio of 2.62 and a debt-to-equity ratio of 0.58. The stock has a market cap of $28.84 billion, a P/E ratio of 13.09, a P/E/G ratio of 1.08 and a beta of 0.89. </p>
<p>PACCAR (<a href='https://www.marketbeat.com/stocks/NASDAQ/PCAR/'>NASDAQ:PCAR</a> &#8211; <a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=PCAR&#038;lead_source=etfdailynews_snra&#038;utm_source=etfdailynews_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=PCAR&#038;utm_content=text_link'>Get Rating</a>) last issued its earnings results on Tuesday, July 26th. The company reported $2.07 earnings per share (EPS) for the quarter, topping analysts&#8217; consensus estimates of $1.81 by $0.26. PACCAR had a return on equity of 18.64% and a net margin of 8.68%. The company had revenue of $6.79 billion for the quarter, compared to analysts&#8217; expectations of $6.57 billion. During the same period last year, the business earned $1.41 EPS. PACCAR&#8217;s quarterly revenue was up 26.0% compared to the same quarter last year. Sell-side analysts anticipate that PACCAR Inc will post 7.73 earnings per share for the current fiscal year. </p>
<h2>PACCAR Increases Dividend</h2>
<p>The business also recently disclosed a quarterly dividend, which will be paid on Tuesday, December 6th. Shareholders of record on Tuesday, November 15th will be paid a dividend of $0.37 per share. The ex-dividend date of this dividend is Monday, November 14th. This is a boost from PACCAR&#8217;s previous quarterly dividend of $0.34. This represents a $1.48 annualized dividend and a yield of 1.78%. PACCAR&#8217;s dividend payout ratio (DPR) is 21.45%. </p>
<h2 style='display:inline-block'>About PACCAR</h2>
<p> (<a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=PCAR&#038;lead_source=etfdailynews_snra&#038;utm_source=etfdailynews_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=PCAR&#038;utm_content=text_link'>Get Rating</a>)</p>
<p>PACCAR Inc designs, manufactures, and distributes light, medium, and heavy-duty commercial trucks in the United States, Europe, Mexico, South America, Australia, and internationally. It operates through three segments: Truck, Parts, and Financial Services. The Truck segment designs, manufactures, and distributes trucks for the over-the-road and off-highway hauling of commercial and consumer goods.</p>
<h2>Featured Stories</h2>
<ul>
<li><a href='https://report.stocknews.com/sign-up/ticker/?ticker=PCAR&#038;lead_source=etfdailynews_snra&#038;utm_source=etfdailynews_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=PCAR&#038;utm_content=text_link' target='_blank' rel="noopener">Get a free copy of the StockNews.com research report on PACCAR (PCAR)</a></li>
<li><a href='https://www.marketbeat.com/originals/defensive-stocks-to-help-you-overcome-volatility/' target='_blank' rel="noopener">Defensive Stocks For A Volatile Market</a></li>
<li><a href='https://www.marketbeat.com/originals/sunpower-is-ready-to-power-up-triple-digit-earnings-gains/' target='_blank' rel="noopener">SunPower Is Ready To Power Up Triple-Digit Earnings Gains</a></li>
<li><a href='https://www.marketbeat.com/originals/will-ups-be-next-to-deliver-a-warning/' target='_blank' rel="noopener">Will UPS Be Next to Deliver a Warning?</a></li>
<li><a href='https://www.marketbeat.com/originals/is-this-the-darkest-before-the-dawn-for-gap-stock/' target='_blank' rel="noopener">Is This the Darkest Before the Dawn for Gap Stock?</a></li>
<li><a href='https://www.marketbeat.com/originals/build-a-better-tech-portfolio-with-jabil-inc/' target='_blank' rel="noopener">Build A Better Tech Portfolio With Jabil Inc.</a></li>
</ul>
<p></p>
<p><strong>Want to see what other hedge funds are holding PCAR?</strong> <a href="https://www.holdingschannel.com/hedge-funds/holding-pcar/">Visit HoldingsChannel.com</a> to get the latest 13F filings and insider trades for PACCAR Inc (<a href="https://www.marketbeat.com/stocks/NASDAQ/PCAR/">NASDAQ:PCAR</a> &#8211; <a style="font-weight:normal;text-decoration:italic;color:green" href="https://report.stocknews.com/sign-up/ticker/?ticker=PCAR&#038;lead_source=etfdailynews_snra&#038;utm_source=etfdailynews_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=PCAR&#038;utm_content=text_link">Get Rating</a>).</p>
<p style="text-align:center"><img loading="lazy" src="https://www.marketbeat.com/scripts/SECFilingChart.ashx?Prefix=NASDAQ&#038;Symbol=PCAR" alt="Institutional Ownership by Quarter for PACCAR (NASDAQ:PCAR)" width="650" height="350" /></p>
<p></p>





<p style="clear:both"><strong>Receive News &amp; Ratings for PACCAR Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for PACCAR and related companies with <a href="/daily-email-updates-basic/?symbol=NASDAQ:PCAR&c=PACCAR" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" aria-label="Your Email Address" class="signup" />
<input type="hidden" id="Hidden3" name="RegistrationCode" value="ETF Daily News-Footer" />
<input type="hidden" id="Hidden4" name="RegisterTicker" value="NASDAQ:PCAR" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>

</div> 


<div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=500&h=300&zc=2&src=https://www.marketbeat.com/logos/paccar-logo.jpg" />
<meta itemprop="width" content="500">
<meta itemprop="height" content="300">
</div>
<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo-02.png">
<meta itemprop="width" content="550">
<meta itemprop="height" content="188">
</div>
<meta itemprop="name" content="ETF Daily News" />
<meta itemprop="url" content="https://etfdailynews.com" />
</div>

</article>

<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx" title="More Headlines"></iframe>


<nav id="prevnext">
<a href="https://www.etfdailynews.com/2022/09/28/monro-inc-nasdaqmnro-shares-purchased-by-state-of-alaska-department-of-revenue/" rel="prev"><div class="previous"><h2 class="h4">&laquo; PREVIOUS HEADLINE</h2><p>Monro, Inc. (NASDAQ:MNRO) Shares Purchased by State of Alaska Department of Revenue</p></div></a> <a href="https://www.etfdailynews.com/2022/09/28/mgm-resorts-international-nysemgm-shares-acquired-by-allworth-financial-lp/" rel="next"><div class="next"><h2 class="h4">NEXT HEADLINE &raquo;</h2><p>MGM Resorts International (NYSE:MGM) Shares Acquired by Allworth Financial LP</p></div></a>
</nav>
<div id="latest-news">
<h2>You might be interested in:</h2>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/036_johnsonandjohnson.png&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="M. Kraus &#038; Co Buys 68 Shares of Johnson &#038; Johnson " />
</div></div>

<a href="https://www.etfdailynews.com/2022/09/28/m-kraus-co-buys-68-shares-of-johnson-johnson-nysejnj/" rel="bookmark">M. Kraus &#038; Co Buys 68 Shares of Johnson &#038; Johnson </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/036_johnsonandjohnson.png&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Cohen Klingenstein LLC Decreases Stock Holdings in Johnson &#038; Johnson " />
</div></div>

<a href="https://www.etfdailynews.com/2022/09/28/cohen-klingenstein-llc-decreases-stock-holdings-in-johnson-johnson-nysejnj/" rel="bookmark">Cohen Klingenstein LLC Decreases Stock Holdings in Johnson &#038; Johnson </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/archer-daniels-midland-co-logo.jpg?v=20200424121557&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Global Retirement Partners LLC Decreases Position in Archer-Daniels-Midland Company " />
</div></div>

<a href="https://www.etfdailynews.com/2022/09/28/global-retirement-partners-llc-decreases-position-in-archer-daniels-midland-company-nyseadm/" rel="bookmark">Global Retirement Partners LLC Decreases Position in Archer-Daniels-Midland Company </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/wells-fargo-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Western Wealth Management LLC Cuts Stake in Wells Fargo &#038; Company " />
</div></div>

<a href="https://www.etfdailynews.com/2022/09/28/western-wealth-management-llc-cuts-stake-in-wells-fargo-company-nysewfc/" rel="bookmark">Western Wealth Management LLC Cuts Stake in Wells Fargo &#038; Company </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/marriott-international-inc-logo.png?v=20200227112206&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Global Retirement Partners LLC Raises Stock Holdings in Marriott International, Inc. " />
</div></div>

<a href="https://www.etfdailynews.com/2022/09/28/global-retirement-partners-llc-raises-stock-holdings-in-marriott-international-inc-nasdaqmar/" rel="bookmark">Global Retirement Partners LLC Raises Stock Holdings in Marriott International, Inc. </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/invesco-dwa-momentum-etf-logo.png?v=20210709132026&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Cambridge Investment Research Advisors Inc. Grows Stock Holdings in Invesco DWA Momentum ETF " />
</div></div>

<a href="https://www.etfdailynews.com/2022/09/28/cambridge-investment-research-advisors-inc-grows-stock-holdings-in-invesco-dwa-momentum-etf-nasdaqpdp/" rel="bookmark">Cambridge Investment Research Advisors Inc. Grows Stock Holdings in Invesco DWA Momentum ETF </a>
</div>
</div>

<br>
</main> 
<aside class="flex-sidebar">
<div class="flex-container">
<div class="sidebar-section">
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx" width="336" height="600" frameborder="no" title="More Articles"></iframe>

</div>
<div class="sidebar-section">


<div class="sidebar-email">
<h3>Daily Ratings &amp; News for PACCAR</h3>
Complete the form below to receive the latest headlines and analysts' recommendations for PACCAR with our free daily email newsletter:<br />
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="RegisterEmailSidebar" style='width:100%' name="RegisterEmail" type="email" placeholder="Your Email Address" aria-label="Your Email Address">
<input type="hidden" id="Hidden7" name="RegistrationCode" value="ETF Daily News-Sidebar">
<input type="hidden" id="Hidden8" name="RegisterTicker" value="NASDAQ:PCAR" /> <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:100%;height:30px">
<div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
</form>
</div>


<br>
<a style="background: #075A8D;color: #fff;padding: 5px 7px 4px;border-radius: 3px;font-size: 12px;text-decoration: none;" href="https://twitter.com/intent/follow?original_referer=https%3A%2F%2Fwww.etfdailynews.com%2F&ref_src=twsrc%5Etfw&screen_name=etfdailynews" target="_blank" rel="noopener nofollow">
<svg style="width: 13px;vertical-align: middle;margin-right: 4px;fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z" /></svg> Follow @etfdailynews</a>



<br />
<div>
<h3>Recent News</h3>
<ul>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/m-kraus-co-buys-68-shares-of-johnson-johnson-nysejnj/">M. Kraus &#038; Co Buys 68 Shares of Johnson &#038; Johnson (NYSE:JNJ)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/cohen-klingenstein-llc-decreases-stock-holdings-in-johnson-johnson-nysejnj/">Cohen Klingenstein LLC Decreases Stock Holdings in Johnson &#038; Johnson (NYSE:JNJ)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/global-retirement-partners-llc-decreases-position-in-archer-daniels-midland-company-nyseadm/">Global Retirement Partners LLC Decreases Position in Archer-Daniels-Midland Company (NYSE:ADM)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/western-wealth-management-llc-cuts-stake-in-wells-fargo-company-nysewfc/">Western Wealth Management LLC Cuts Stake in Wells Fargo &#038; Company (NYSE:WFC)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/global-retirement-partners-llc-raises-stock-holdings-in-marriott-international-inc-nasdaqmar/">Global Retirement Partners LLC Raises Stock Holdings in Marriott International, Inc. (NASDAQ:MAR)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/cambridge-investment-research-advisors-inc-grows-stock-holdings-in-invesco-dwa-momentum-etf-nasdaqpdp/">Cambridge Investment Research Advisors Inc. Grows Stock Holdings in Invesco DWA Momentum ETF (NASDAQ:PDP)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/carnival-co-plc-nyseccl-shares-bought-by-allworth-financial-lp/">Carnival Co. &#038; plc (NYSE:CCL) Shares Bought by Allworth Financial LP</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/oak-asset-management-llc-has-227000-stake-in-alphabet-inc-nasdaqgoogl/">Oak Asset Management LLC Has $227,000 Stake in Alphabet Inc. (NASDAQ:GOOGL)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/meyer-handelman-co-buys-115-shares-of-alphabet-inc-nasdaqgoogl/">Meyer Handelman Co. Buys 115 Shares of Alphabet Inc. (NASDAQ:GOOGL)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/karp-capital-management-corp-trims-position-in-alphabet-inc-nasdaqgoogl/">Karp Capital Management Corp Trims Position in Alphabet Inc. (NASDAQ:GOOGL)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/ritholtz-wealth-management-boosts-position-in-alphabet-inc-nasdaqgoogl/">Ritholtz Wealth Management Boosts Position in Alphabet Inc. (NASDAQ:GOOGL)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/orion-portfolio-solutions-llc-raises-stock-position-in-lyondellbasell-industries-nyselyb/">Orion Portfolio Solutions LLC Raises Stock Position in LyondellBasell Industries (NYSE:LYB)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/engrave-wealth-partners-llc-trims-stock-holdings-in-microsoft-co-nasdaqmsft/">Engrave Wealth Partners LLC Trims Stock Holdings in Microsoft Co. (NASDAQ:MSFT)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/ritholtz-wealth-management-sells-691-shares-of-intercontinental-exchange-inc-nyseice/">Ritholtz Wealth Management Sells 691 Shares of Intercontinental Exchange, Inc. (NYSE:ICE)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/microsoft-co-nasdaqmsft-is-private-harbour-investment-management-counsel-llcs-4th-largest-position/">Microsoft Co. (NASDAQ:MSFT) is Private Harbour Investment Management &#038; Counsel LLC&#8217;s 4th Largest Position</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/retirement-planning-group-grows-holdings-in-microsoft-co-nasdaqmsft/">Retirement Planning Group Grows Holdings in Microsoft Co. (NASDAQ:MSFT)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/rockland-trust-co-boosts-stock-holdings-in-microsoft-co-nasdaqmsft/">Rockland Trust Co. Boosts Stock Holdings in Microsoft Co. (NASDAQ:MSFT)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/fusion-capital-llc-has-4-30-million-stock-holdings-in-microsoft-co-nasdaqmsft/">Fusion Capital LLC Has $4.30 Million Stock Holdings in Microsoft Co. (NASDAQ:MSFT)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/hbw-advisory-services-llc-grows-position-in-microsoft-co-nasdaqmsft/">HBW Advisory Services LLC Grows Position in Microsoft Co. (NASDAQ:MSFT)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/09/28/mezzasalma-advisors-llc-purchases-470-shares-of-microsoft-co-nasdaqmsft/">Mezzasalma Advisors LLC Purchases 470 Shares of Microsoft Co. (NASDAQ:MSFT)</a></li>
</ul>
</div>
</div>
</div>

</aside>
<div style="clear: both;"></div>
</div> 
<footer class="full-width">
<div class="width-limiter flex-container">
<div id="footer-info" class="add-padding flex-nav">
</div>
<span id="copyright" class="add-padding flex-copyright">
&copy; 2018-2022 <a href="https://www.etfdailynews.com">ETF Daily News</a>
</span>
</div>

<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/standalone/viewcount.ashx?ArticleHistoryID=95785299&PostDate=2022-9-28&type=f&id=12911534&domain=www.etfdailynews.com&referrer=' + encodeURIComponent(document.referrer) + '" alt="" width="1" height="1" style="float:left;" />');</script>

</footer>
</div>

<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1" alt=""></noscript>


<script type="text/javascript">
var sc_project=12682890; 
var sc_invisible=1; 
var sc_security="f2745ebe"; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/12682890/0/f2745ebe/1/" height="1" width="1"  alt=""></noscript>

</body>
</html>
