<!doctype html>
<html lang="en">
<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="google-site-verification" content="swFzT9uWAz-P-dtjcCuwxp3R6yIBLsXkeqbwG3n9x_o" />
<meta name="theme-color" content="#b71c32" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">

<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script>
<link rel="preconnect" href="https://fonts.gstatic.com">
<link href="https://fonts.googleapis.com/css2?family=Copse&family=Lato&display=swap" rel="stylesheet">
<style>

:root {
  --header-background: #ffffff;
  --button-background: #b71c32;
  --button-background-2: #88021d;
  --button-hover-background: #b71c32;
  --button-hover-background-2: #b71c32;
  --button-text-color: #fff;
  --link-color: #257192;
  --link-hover-color: #288aa3;
  --link-text-decoration: none; /* text field */
  --hover-link-text-decoration: underline; /* text field */
  --menu-background: #111111;
  --menu-background-2: #111111;
  --menu-text-color: #fff;
  --menu-active-hover-background: #257192;
  --menu-active-hover-text-color: #fff;
  --top-menu-background: #eff2f4;
  --top-menu-link-color: #257192;
  --top-menu-link-hover-color: #164f5d;
  --accent-color: #257192;
  --accent-color-2: #257192;
  --sidebar-h3-color: #257192;
  --light-gray-color:#eff2f4;
  --light-gray-link-color:#eff2f4;
  --light-gray-link-hover-color:#eff2f4;
  --list-item-bottom-border: solid 1px #eff2f4;
  --border-radius: 3px;
  --border-radius-small-items: 1px;
  --H1-font: 2.1em/1.3 "Copse",serif;
  --H2-font:  1.4em/1.3 "Copse",serif;
  --H3-font:  bold uppercase 1.1em/1.3 "Lato",sans-serif;
  --body-font: 15px "Lato",sans-serif;
  --menu-font: 1em "Lato", sans-serif;
  --box-shadow: 0px 0px 1px 0px #eff2f4; 
  --body-background: #257192;
  --body-background-2: #111111;
  --body-font-color: #111111;

}


body {
	font: var(--body-font);
    background: var(--body-background);
	color: var(--body-font-color);
	 
		
	background: -moz-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -webkit-gradient(left top,left bottom,color-stop(0%, var(--body-background)),color-stop(100%, var(--body-background-2)));
    background: -webkit-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -o-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -ms-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: linear-gradient(to bottom, var(--body-background) 0%, var(--body-background-2) 100%);
		
    background-attachment: fixed;
    background-size: cover;
}

</style>
<link rel="stylesheet" href="https://www.etfdailynews.com/wp-content/themes/responsalambre/style.css?v=2021abcdefghij" type="text/css" media="screen">
<link href="https://www.etfdailynews.com/feed/" rel="alternate" title="ETF Daily News RSS Feed" type="application/rss+xml" />
<link href="https://www.etfdailynews.com/feed/atom/" rel="alternate" title="ETF Daily News Atom Feed" type="application/atom+xml" />
<link href="https://www.etfdailynews.com/xmlrpc.php" rel="pingback" />
<meta name='robots' content='max-image-preview:large' />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.etfdailynews.com/wp-includes/css/dist/block-library/style.min.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='classic-theme-styles-css' href='https://www.etfdailynews.com/wp-includes/css/classic-themes.min.css?ver=1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel="https://api.w.org/" href="https://www.etfdailynews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.etfdailynews.com/wp-json/wp/v2/posts/1318273" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.etfdailynews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.etfdailynews.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.1.1" />
<link rel="canonical" href="https://www.etfdailynews.com/2022/12/09/renaissance-technologies-llc-purchases-513100-shares-of-comstock-resources-inc-nysecrk/" />
<link rel='shortlink' href='https://www.etfdailynews.com/?p=1318273' />
<link rel="alternate" type="application/json+oembed" href="https://www.etfdailynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F12%2F09%2Frenaissance-technologies-llc-purchases-513100-shares-of-comstock-resources-inc-nysecrk%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.etfdailynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F12%2F09%2Frenaissance-technologies-llc-purchases-513100-shares-of-comstock-resources-inc-nysecrk%2F&#038;format=xml" />
<link rel="manifest" href="https://www.etfdailynews.com/manifest.json"><link rel="icon" href="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo_etf-icon-1-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo_etf-icon-1-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo_etf-icon-1-300x300.png" />
<meta name="msapplication-TileImage" content="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo_etf-icon-1-300x300.png" />

<title>Renaissance Technologies LLC Purchases 513,100 Shares of Comstock Resources, Inc. (NYSE:CRK) - ETF Daily News</title>
<meta name="description" content="Read Renaissance Technologies LLC Purchases 513,100 Shares of Comstock Resources, Inc. (NYSE:CRK) at ETF Daily News" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="description" content="Renaissance Technologies LLC raised its position in Comstock Resources, Inc. (NYSE:CRK &#8211; Get Rating) by 79.4% during the second quarter, Holdings Channel reports. The institutional investor owned 1,159,600 shares of the oil and gas producer&#8217;s stock after buying an additional 513,100 shares during the quarter. Renaissance Technologies LLC&#8217;s holdings in Comstock Resources were worth $14,008,000 [&hellip;]" />
<meta name="author" content="MarketBeat News">
<meta name="news_keywords" content="Comstock Resources,NYSE:CRK,CRK,Oils/Energy,20576820,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="keywords" content="Comstock Resources,NYSE:CRK,CRK,Oils/Energy,20576820,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="ticker" content="NYSE:CRK" />
<meta name="contentType" content="article">

<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@MarketBeatCom" />
<meta name="twitter:title" content="Renaissance Technologies LLC Purchases 513,100 Shares of Comstock Resources, Inc. (NYSE:CRK)" />
<meta name="twitter:description" content="Renaissance Technologies LLC raised its position in Comstock Resources, Inc. (NYSE:CRK &#8211; Get Rating) by 79.4% during the second quarter, Holdings Channel reports. The institutional investor owned 1,159,600 shares of the oil and gas producer&#8217;s stock after buying an additional 513,100 shares during the quarter. Renaissance Technologies LLC&#8217;s holdings in Comstock Resources were worth $14,008,000 [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/comstock-resources-inc-logo.gif&amp;w=240&amp;h=240&amp;zc=2" />

<meta property="og:title" content="Renaissance Technologies LLC Purchases 513,100 Shares of Comstock Resources, Inc. (NYSE:CRK)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.etfdailynews.com/2022/12/09/renaissance-technologies-llc-purchases-513100-shares-of-comstock-resources-inc-nysecrk/" />
<meta property="og:image" content="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/comstock-resources-inc-logo.gif&amp;w=240&amp;h=240&amp;zc=2" />
<meta property="og:image:width" content="240" />
<meta property="og:image:height" content="240" />
<meta property="og:description" content="Renaissance Technologies LLC raised its position in Comstock Resources, Inc. (NYSE:CRK &#8211; Get Rating) by 79.4% during the second quarter, Holdings Channel reports. The institutional investor owned 1,159,600 shares of the oil and gas producer&#8217;s stock after buying an additional 513,100 shares during the quarter. Renaissance Technologies LLC&#8217;s holdings in Comstock Resources were worth $14,008,000 [&hellip;]" />
<meta property="og:site_name" content="ETF Daily News" />
<meta property="og:locale" content="en_US" />

<meta property="article:published_time" content="2022-12-09T12:38:41+0000" />
<meta property="article:modified_time" content="2022-12-09T12:38:41+0000" />
<meta property="article:tag" content="NYSE:CRK" />
<meta property="article:tag" content="Comstock Resources,NYSE:CRK,CRK,Oils/Energy,20576820,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta property="article:section" content="Markets" />


<script type='text/javascript'>var PopupAdChannel=''; </script>
<link rel="manifest" href="/manifest.json">
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
<script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'etfdailynews.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "cca79df0-f0c0-4b3f-906c-d1d378701b61",
      safari_web_id: '', 
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}  </script>
<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>
<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=2021"></script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {

	var responsiveAdSlot = googletag.defineSlot('/21771534901/ETF',[[728, 90], [300, 250]], 'div-gpt-ad-1663600271841-0').addService(googletag.pubads());
	var mapping = googletag.sizeMapping().addSize([1024, 0], [[728, 90]]).addSize([0, 0], [300, 250]).build();
	responsiveAdSlot.defineSizeMapping(mapping);
	googletag.pubads().enableSingleRequest();
	googletag.enableServices();

  });

</script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21771534901/ETF', [300, 250], 'div-gpt-ad-1646836411098-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-8025563-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-8025563-1');
</script>
<script src="https://ef53b36683c44880ae01202dedb7e921.js.ubembed.com" async></script>
</head>
<body>
<div id="wrap">

<a class="skip-link scroll" href="#main">Skip to main content</a>
<header>
<div class="width-limiter background-light top-menu-bar">
<div style='color:#222;text-align:right;'>
</div>
</div>

<div class="width-limiter top-mobile-menu" id='mobile-logo-bar'>
<label for="nav-trigger" style="display:inline-block; width:30vw; color:#12424d;vertical-align:middle;">&#9776;</label>
<a style='vertical-align:middle;width:33vw;display:inline-block;text-align:center;padding:5px;' href="https://www.etfdailynews.com"><img style='width:120px' src="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo-02.png" alt="ETF Daily News logo" width="550" height="188"></a>
</div>
<div class="width-limiter" style="min-height: 5px;" id='mobile-menu-bar'>
<input type="checkbox" id="nav-trigger" class="navOpen" />
<div class="mobile-nav nice-scroll">
<nav class="mobile-menu" aria-label="Category Mobile Menu"><ul id="menu-main-menu" class="menu"><li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://www.etfdailynews.com/category/markets/analyst-articles-us/">Analyst Ratings</a></li>
<li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.etfdailynews.com/category/markets/cryptocurrencies/">Crypto</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://www.etfdailynews.com/category/markets/earnings-articles-single/">Earnings</a></li>
<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://www.etfdailynews.com/category/markets/insider-trades/">Insider Trades</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://www.etfdailynews.com/category/markets/ipo-articles/">IPOs</a></li>
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://www.etfdailynews.com/category/markets/options-articles/">Options</a></li>
</ul></nav>
<form class="mobile-search" id="mobileSearchForm" action="https://www.etfdailynews.com/" method="get">
<div class="search">
<input id="s" style='margin-left:0;' class="searchinput" aria-label="Search Keywords" name="s" onclick="this.value='';" type="text" />
<input class="searchsubmit" type="submit" value="SEARCH" />
</div>
</form>
<div>
</div>
</div>
</div>

<div class="width-limiter add-padding flex-container">
<a class="logo-link flex-logo" id="header-logo-link" href="https://www.etfdailynews.com" title="ETF Daily News"><img id="logo" src="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo-02.png" alt="ETF Daily News logo" width="550" height="188"></a>

<div id="AlternateHeaderUnit" class="flex-header-ad">

<div id='div-gpt-ad-1663600271841-0' style='min-width: 300px; min-height: 90px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1663600271841-0'); });
  </script>
</div>
</div>

</div> 
<div id="menu">
<div class="width-limiter flex-container" id="nav-main">

<div class="flex-nav">
<nav class="navigation" aria-label="Main Menu"><ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://www.etfdailynews.com/category/markets/analyst-articles-us/">Analyst Ratings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.etfdailynews.com/category/markets/cryptocurrencies/">Crypto</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://www.etfdailynews.com/category/markets/earnings-articles-single/">Earnings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://www.etfdailynews.com/category/markets/insider-trades/">Insider Trades</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://www.etfdailynews.com/category/markets/ipo-articles/">IPOs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://www.etfdailynews.com/category/markets/options-articles/">Options</a></li>
</ul></nav>
</div>
<form class="flex-search" id="searchform" action="https://www.etfdailynews.com/" method="get">
<div class="search">
<input id="s-main" class="searchinput" name="s" aria-label="Search Keywords" onclick="this.value='';" type="text" />
<input class="searchsubmit" type="submit" value="SEARCH" />
</div>
</form>
</div> 
</div> 
</header> 
<div class="width-limiter main-content flex-container">
<main class="flex-main" id="main">
<article itemscope itemtype="http://schema.org/NewsArticle">
<link itemprop="mainEntityOfPage" href="https://www.etfdailynews.com/2022/12/09/renaissance-technologies-llc-purchases-513100-shares-of-comstock-resources-inc-nysecrk/" />
<h1 itemprop="headline" class="page-title">Renaissance Technologies LLC Purchases 513,100 Shares of Comstock Resources, Inc. (NYSE:CRK)</h1>
<p class="postmeta">
Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://www.etfdailynews.com/author/marketbeat/" title="Posts by MarketBeat News" rel="author">MarketBeat News</a></span></span> on <span itemprop="datePublished dateModified" content="2022-12-09T12:38:41+0000">Dec 9th, 2022</span>
</p>
<div class="social-shares">
<a title="Share on Twitter" rel="noopener nofollow" target="_blank" style="background: #1DA1F2;" href="https://twitter.com/intent/tweet?original_referer=https%3A%2F%2Fwww.etfdailynews.com&ref_src=twsrc%5Etfw&text=Renaissance%20Technologies%20LLC%20Purchases%20513%2C100%20Shares%20of%20Comstock%20Resources%2C%20Inc.%20%28NYSE%3ACRK%29%20%24CRK&tw_p=tweetbutton&url=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F12%2F09%2Frenaissance-technologies-llc-purchases-513100-shares-of-comstock-resources-inc-nysecrk%2F&via=etfdailynews"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z" /></svg></span><span class="share-title">Share on Twitter</span></a>
<a title="Share on Facebook" rel="noopener nofollow" target="_blank" style="background:#4267B2;" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F12%2F09%2Frenaissance-technologies-llc-purchases-513100-shares-of-comstock-resources-inc-nysecrk%2F"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z" /></svg></span><span class="share-title">Share on Facebook</span></a>
<a title="Share on LinkedIn" rel="noopener nofollow" target="_blank" style="background: #0067b1;" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.etfdailynews.com%2F2022%2F12%2F09%2Frenaissance-technologies-llc-purchases-513100-shares-of-comstock-resources-inc-nysecrk%2F"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z" /></svg></span><span class="share-title">Share on LinkedIn</span></a>
<a title="Share on Stocktwits" rel="noopener nofollow" style="background:#228dff;" href="https://api.stocktwits.com/widgets/share?via=MarketBeat&amp;body=Renaissance%20Technologies%20LLC%20Purchases%20513%2C100%20Shares%20of%20Comstock%20Resources%2C%20Inc.%20%28NYSE%3ACRK%29%20%24CRK" title="Share on StockTwits"><span class="share-button"><svg style="fill:#fff;" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="24" height="24" viewBox="0 0 30 30" style="enable-background:new 0 0 30 30;" xml:space="preserve"><polygon class="st0" points="21.98,17.75 21.98,13.29 14.54,9.67 21.98,6.19 21.98,1.84 9.02,8.45 9.02,11.12 " /><polygon class="st0" points="9.07,13.19 9.07,17.65 16.49,21.27 9.07,24.76 9.07,29.1 21.98,22.49 21.98,19.82 " /></svg></span><span class="share-title">Share on Stocktwits</span></a>
</div>
<div style="clear:both"></div>

<div class="entry" itemprop="articleBody">

<p><img decoding="async" src="https://www.marketbeat.com/logos/comstock-resources-inc-logo.gif" alt="Comstock Resources logo" title="Comstock Resources" class="companylogo" />Renaissance Technologies LLC raised its position in Comstock Resources, Inc. (<a href="https://www.marketbeat.com/stocks/NYSE/CRK/">NYSE:CRK</a> &#8211; <a style="font-weight:normal;text-decoration:italic;color:green" href="https://report.stocknews.com/sign-up/ticker/?ticker=CRK&#038;lead_source=etfdailynews_snra&#038;utm_source=etfdailynews_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=CRK&#038;utm_content=text_link">Get Rating</a>) by 79.4% during the second quarter, <a href="http://www.holdingschannel.com/">Holdings Channel</a> reports. The institutional investor owned 1,159,600 shares of the oil and gas producer&#8217;s stock after buying an additional 513,100 shares during the quarter. Renaissance Technologies LLC&#8217;s holdings in Comstock Resources were worth $14,008,000 at the end of the most recent quarter. </p>
<p>Other hedge funds and other institutional investors have also made changes to their positions in the company. CoreCap Advisors LLC bought a new position in shares of Comstock Resources in the 2nd quarter worth $32,000. Cullen Frost Bankers Inc. bought a new position in shares of Comstock Resources in the 2nd quarter worth $48,000. Ellevest Inc. boosted its position in shares of Comstock Resources by 33.3% in the 2nd quarter. Ellevest Inc. now owns 8,145 shares of the oil and gas producer&#8217;s stock worth $98,000 after purchasing an additional 2,035 shares during the last quarter. Lido Advisors LLC bought a new position in shares of Comstock Resources in the 1st quarter worth $131,000. Finally, State Board of Administration of Florida Retirement System bought a new position in shares of Comstock Resources in the 2nd quarter worth $135,000. 34.02% of the stock is currently owned by institutional investors. </p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
<input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-ETF Daily News" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:CRK" /> <label for="InPostRegistrationEmail">Get <b>Comstock Resources</b> alerts:</label>
<div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 0.9em;line-height: 1em;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" class="button" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;font-size: 0.9em;font-weight: 700;line-height: 1em;padding: 6px 18px"></div>
</form>
<div id="ShowSuggestionInPost"></div>
<h2>Comstock Resources Stock Performance</h2>
<p><a href='https://www.marketbeat.com/stocks/NYSE/CRK/sec-filings/' target='_blank' rel="noopener">CRK</a> opened at $14.11 on Friday. The business&#8217;s 50-day moving average price is $17.88 and its two-hundred day moving average price is $17.17. Comstock Resources, Inc. has a 1 year low of $6.88 and a 1 year high of $22.11. The company has a market capitalization of $3.30 billion, a price-to-earnings ratio of 4.10 and a beta of 1.29. The company has a debt-to-equity ratio of 1.40, a current ratio of 0.65 and a quick ratio of 0.65. </p>
<h2>Comstock Resources Dividend Announcement</h2>
<p>
<div class="in-article-ad">

<div id='div-gpt-ad-1646836411098-0' style='min-width: 305px; min-height: 250px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1646836411098-0'); });
  </script>
</div>
<div style="padding-top:1em;">
<strong>Want More Great Investing Ideas?</strong>
<ul>
<li><a href="https://report.stocknews.com/rtrsignup/?formplacement=artbottomrtr_etf" target="_blank"><span style="color:#d32f2f;">Bear Market Game Plan!</span></a></li>
<li><a href="https://www.marketbeat.com/newsletter/PDFoffer.aspx?offer=newyear&RegistrationCode=ETFDailyNews" target="_blank"><span style="color:#d32f2f;">The 10 Best Stocks to Own in 2022</span></a></li>
<li><a href="https://www.marketbeat.com/newsletter/PDFoffer.aspx?offer=buyandhold&RegistrationCode=ETFDailyNews" target="_blank"><span style="color:#d32f2f;">7 Stocks to Buy and Hold Forever</span></a></li>
<li><a href="https://report.stocknews.com/free-report/3stocks/?formplacement=artbottom3s_etf" target="_blank"><span style="color:#d32f2f;">3 Stocks to DOUBLE This Year</span></a></li>
</ul>
</div>
</div>
The business also recently announced a quarterly dividend, which will be paid on Thursday, December 15th. Investors of record on Thursday, December 1st will be given a $0.125 dividend. This represents a $0.50 dividend on an annualized basis and a dividend yield of 3.54%. The ex-dividend date is Wednesday, November 30th. Comstock Resources&#8217;s dividend payout ratio is currently 14.53%. </p>
<h2>Wall Street Analysts Forecast Growth</h2>
<p>Several research firms have recently issued reports on CRK. Citigroup lowered Comstock Resources from a &#8220;buy&#8221; rating to a &#8220;sell&#8221; rating and reduced their price target for the stock from $24.00 to $14.00 in a research report on Wednesday. KeyCorp dropped their price objective on Comstock Resources from $26.00 to $21.00 and set an &#8220;overweight&#8221; rating on the stock in a research note on Thursday. Tudor, Pickering, Holt &#038; Co. assumed coverage on Comstock Resources in a research note on Wednesday, November 16th. They set a &#8220;hold&#8221; rating on the stock. Stifel Nicolaus raised their price objective on Comstock Resources from $22.00 to $27.00 and gave the stock a &#8220;buy&#8221; rating in a research note on Monday, September 12th. Finally, The Goldman Sachs Group raised their price objective on Comstock Resources from $12.00 to $13.50 and gave the stock a &#8220;sell&#8221; rating in a research note on Monday, August 22nd. Two analysts have rated the stock with a sell rating, five have issued a hold rating and three have issued a buy rating to the stock. According to data from MarketBeat.com, Comstock Resources has an average rating of &#8220;Hold&#8221; and a consensus target price of $18.00.</p>
<h2>Insider Activity at Comstock Resources</h2>
<p>In related news, Director Morris E. Foster bought 8,000 shares of the stock in a transaction that occurred on Thursday, September 22nd. The shares were acquired at an average price of $18.18 per share, with a total value of $145,440.00. Following the completion of the transaction, the director now owns 152,084 shares in the company, valued at $2,764,887.12. The transaction was disclosed in a filing with the Securities &amp; Exchange Commission, which is accessible through <a href='http://www.sec.gov/Archives/edgar/data/23194/000156218022006801/xslF345X03/primarydocument.xml' target='_blank' rel="noopener">this link</a>. In other news, Director Morris E. Foster acquired 8,000 shares of Comstock Resources stock in a transaction dated Thursday, September 22nd. The stock was bought at an average price of $18.18 per share, for a total transaction of $145,440.00. Following the completion of the acquisition, the director now directly owns 152,084 shares in the company, valued at approximately $2,764,887.12. The transaction was disclosed in a legal filing with the SEC, which is accessible through <a href='http://www.sec.gov/Archives/edgar/data/23194/000156218022006801/xslF345X03/primarydocument.xml' target='_blank' rel="noopener">this link</a>. Also, Director Morris E. Foster purchased 14,000 shares of the business&#8217;s stock in a transaction that occurred on Friday, September 16th. The stock was bought at an average price of $18.16 per share, with a total value of $254,240.00. Following the completion of the purchase, the director now owns 144,084 shares of the company&#8217;s stock, valued at approximately $2,616,565.44. The disclosure for this purchase can be found <a href='http://www.sec.gov/Archives/edgar/data/23194/000156218022006694/xslF345X03/primarydocument.xml' target='_blank' rel="noopener">here</a>. Over the last quarter, insiders have purchased 72,000 shares of company stock valued at $1,374,680. 1.20% of the stock is owned by insiders. </p>
<h2 style='display:inline-block'>About Comstock Resources</h2>
<p> (<a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=CRK&#038;lead_source=etfdailynews_snra&#038;utm_source=etfdailynews_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=CRK&#038;utm_content=text_link'>Get Rating</a>)</p>
<p>Comstock Resources, Inc, an independent energy company, engages in the acquisition, exploration, development, and production of oil and natural gas primarily in North Louisiana and East Texas, the United States. As of December 31, 2021, the company had 6.1 trillion cubic feet of the natural gas equivalent of proved reserves.</p>
<h2>Featured Articles</h2>
<ul>
<li><a href='https://report.stocknews.com/sign-up/ticker/?ticker=CRK&#038;lead_source=etfdailynews_snra&#038;utm_source=etfdailynews_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=CRK&#038;utm_content=text_link' target='_blank' rel="noopener">Get a free copy of the StockNews.com research report on Comstock Resources (CRK)</a></li>
<li><a href='https://www.marketbeat.com/originals/can-pfizer-j-and-j-continue-outperforming-the-index/' target='_blank' rel="noopener">Can Pfizer, Johnson &#038; Johnson Continue Outperforming the Index?</a></li>
<li><a href='https://www.marketbeat.com/originals/this-is-why-daktronics-fell-40-in-one-day/' target='_blank' rel="noopener">This Is Why Daktronics Fell 40% In One Day </a></li>
<li><a href='https://www.marketbeat.com/originals/is-it-time-to-throw-in-the-towel-on-gamestop/' target='_blank' rel="noopener">Is It Time To Throw In The Towel On Gamestop?</a></li>
<li><a href='https://www.marketbeat.com/originals/why-you-should-avoid-carvana-even-if-it-avoids-bankruptcy/' target='_blank' rel="noopener">Why You Should Avoid Carvana Even if it Avoids Bankruptcy</a></li>
<li><a href='https://www.marketbeat.com/originals/are-investors-hearing-the-end-of-spotifys-downtrend/' target='_blank' rel="noopener">Are Investors Hearing The End Of Spotify&#8217;s Downtrend? </a></li>
</ul>
<p></p>
<p><strong>Want to see what other hedge funds are holding CRK?</strong> <a href="https://www.holdingschannel.com/hedge-funds/holding-crk/">Visit HoldingsChannel.com</a> to get the latest 13F filings and insider trades for Comstock Resources, Inc. (<a href="https://www.marketbeat.com/stocks/NYSE/CRK/">NYSE:CRK</a> &#8211; <a style="font-weight:normal;text-decoration:italic;color:green" href="https://report.stocknews.com/sign-up/ticker/?ticker=CRK&#038;lead_source=etfdailynews_snra&#038;utm_source=etfdailynews_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=CRK&#038;utm_content=text_link">Get Rating</a>).</p>
<p style="text-align:center"><img decoding="async" loading="lazy" src="https://www.marketbeat.com/scripts/SECFilingChart.ashx?Prefix=NYSE&#038;Symbol=CRK" alt="Institutional Ownership by Quarter for Comstock Resources (NYSE:CRK)" width="650" height="350" /></p>
<p></p>





<p style="clear:both"><strong>Receive News &amp; Ratings for Comstock Resources Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Comstock Resources and related companies with <a href="/daily-email-updates-basic/?symbol=NYSE:CRK&c=Comstock+Resources" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" aria-label="Your Email Address" class="signup" />
<input type="hidden" id="Hidden3" name="RegistrationCode" value="ETF Daily News-Footer" />
<input type="hidden" id="Hidden4" name="RegisterTicker" value="NYSE:CRK" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>

</div> 


<div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=500&h=300&zc=2&src=https://www.marketbeat.com/logos/comstock-resources-inc-logo.gif" />
<meta itemprop="width" content="500">
<meta itemprop="height" content="300">
</div>
<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://www.etfdailynews.com/wp-content/uploads/2022/03/etf-daily-news-logo-02.png">
<meta itemprop="width" content="550">
<meta itemprop="height" content="188">
</div>
<meta itemprop="name" content="ETF Daily News" />
<meta itemprop="url" content="https://etfdailynews.com" />
</div>

</article>

<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx" title="More Headlines"></iframe>


<nav id="prevnext">
<a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-lowers-holdings-in-the-liberty-siriusxm-group-nasdaqlsxma/" rel="prev"><div class="previous"><h2 class="h4">&laquo; PREVIOUS HEADLINE</h2><p>Zurcher Kantonalbank Zurich Cantonalbank Lowers Holdings in The Liberty SiriusXM Group (NASDAQ:LSXMA)</p></div></a> <a href="https://www.etfdailynews.com/2022/12/09/northern-trust-corp-sells-14394-shares-of-national-fuel-gas-nysenfg/" rel="next"><div class="next"><h2 class="h4">NEXT HEADLINE &raquo;</h2><p>Northern Trust Corp Sells 14,394 Shares of National Fuel Gas (NYSE:NFG)</p></div></a>
</nav>
<div id="latest-news">
<h2>You might be interested in:</h2>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/Southwestern-Energy-logo-300x130.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Zurcher Kantonalbank Zurich Cantonalbank Acquires 24,544 Shares of Southwestern Energy " />
</div></div>

<a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-acquires-24544-shares-of-southwestern-energy-nyseswn/" rel="bookmark">Zurcher Kantonalbank Zurich Cantonalbank Acquires 24,544 Shares of Southwestern Energy </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/science-applications-intl-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Zurcher Kantonalbank Zurich Cantonalbank Sells 691 Shares of Science Applications International Co. " />
</div></div>

<a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-sells-691-shares-of-science-applications-international-co-nysesaic-2/" rel="bookmark">Zurcher Kantonalbank Zurich Cantonalbank Sells 691 Shares of Science Applications International Co. </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/polaris-inc-logo.jpg?v=20221111150315&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Zurcher Kantonalbank Zurich Cantonalbank Sells 1,144 Shares of Polaris Inc. " />
</div></div>

<a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-sells-1144-shares-of-polaris-inc-nysepii/" rel="bookmark">Zurcher Kantonalbank Zurich Cantonalbank Sells 1,144 Shares of Polaris Inc. </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=<br />
<b>Warning</b>:  Undefined array key 0 in <b>/home/etfdailynews/public_html/wp-content/themes/responsalambre/functions.php</b> on line <b>144</b><br />
wp-content/themes/responsalambre/images/image-pending.gif&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Are You Ready for the Bear Market to Return?" />
</div></div>

<a href="https://www.etfdailynews.com/2022/12/09/are-you-ready-for-the-bear-market-to-return/" rel="bookmark">Are You Ready for the Bear Market to Return?</a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/Southwestern-Energy-logo-300x130.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Zurcher Kantonalbank Zurich Cantonalbank Raises Stock Holdings in Southwestern Energy " />
</div></div>

<a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-raises-stock-holdings-in-southwestern-energy-nyseswn/" rel="bookmark">Zurcher Kantonalbank Zurich Cantonalbank Raises Stock Holdings in Southwestern Energy </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/liberty-media-corporation-logo.png&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="The Liberty SiriusXM Group  Shares Sold by Zurcher Kantonalbank Zurich Cantonalbank" />
</div></div>

<a href="https://www.etfdailynews.com/2022/12/09/the-liberty-siriusxm-group-nasdaqlsxma-shares-sold-by-zurcher-kantonalbank-zurich-cantonalbank/" rel="bookmark">The Liberty SiriusXM Group Shares Sold by Zurcher Kantonalbank Zurich Cantonalbank</a>
</div>
</div>

<br>
</main> 
<aside class="flex-sidebar">
<div class="flex-container">
<div class="sidebar-section">
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx" width="336" height="600" frameborder="no" title="More Articles"></iframe>

</div>
<div class="sidebar-section">


<div class="sidebar-email">
<h3>Daily Ratings &amp; News for Comstock Resources</h3>
Complete the form below to receive the latest headlines and analysts' recommendations for Comstock Resources with our free daily email newsletter:<br />
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="RegisterEmailSidebar" style='width:100%' name="RegisterEmail" type="email" placeholder="Your Email Address" aria-label="Your Email Address">
<input type="hidden" id="Hidden7" name="RegistrationCode" value="ETF Daily News-Sidebar">
<input type="hidden" id="Hidden8" name="RegisterTicker" value="NYSE:CRK" /> <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:100%;height:30px">
<div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
</form>
</div>


<br>
<a style="background: #075A8D;color: #fff;padding: 5px 7px 4px;border-radius: 3px;font-size: 12px;text-decoration: none;" href="https://twitter.com/intent/follow?original_referer=https%3A%2F%2Fwww.etfdailynews.com%2F&ref_src=twsrc%5Etfw&screen_name=etfdailynews" target="_blank" rel="noopener nofollow">
<svg style="width: 13px;vertical-align: middle;margin-right: 4px;fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z" /></svg> Follow @etfdailynews</a>



<br />
<div>
<h3>Recent News</h3>
<ul>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-acquires-24544-shares-of-southwestern-energy-nyseswn/">Zurcher Kantonalbank Zurich Cantonalbank Acquires 24,544 Shares of Southwestern Energy (NYSE:SWN)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-sells-691-shares-of-science-applications-international-co-nysesaic-2/">Zurcher Kantonalbank Zurich Cantonalbank Sells 691 Shares of Science Applications International Co. (NYSE:SAIC)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-sells-1144-shares-of-polaris-inc-nysepii/">Zurcher Kantonalbank Zurich Cantonalbank Sells 1,144 Shares of Polaris Inc. (NYSE:PII)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/are-you-ready-for-the-bear-market-to-return/">Are You Ready for the Bear Market to Return?</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-raises-stock-holdings-in-southwestern-energy-nyseswn/">Zurcher Kantonalbank Zurich Cantonalbank Raises Stock Holdings in Southwestern Energy (NYSE:SWN)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/the-liberty-siriusxm-group-nasdaqlsxma-shares-sold-by-zurcher-kantonalbank-zurich-cantonalbank/">The Liberty SiriusXM Group (NASDAQ:LSXMA) Shares Sold by Zurcher Kantonalbank Zurich Cantonalbank</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-sells-53663-shares-of-itt-inc-nyseitt/">Zurcher Kantonalbank Zurich Cantonalbank Sells 53,663 Shares of ITT Inc. (NYSE:ITT)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-has-678000-holdings-in-polaris-inc-nysepii/">Zurcher Kantonalbank Zurich Cantonalbank Has $678,000 Holdings in Polaris Inc. (NYSE:PII)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-has-636000-stock-holdings-in-healthequity-inc-nasdaqhqy/">Zurcher Kantonalbank Zurich Cantonalbank Has $636,000 Stock Holdings in HealthEquity, Inc. (NASDAQ:HQY)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-sells-541-shares-of-landstar-system-inc-nasdaqlstr/">Zurcher Kantonalbank Zurich Cantonalbank Sells 541 Shares of Landstar System, Inc. (NASDAQ:LSTR)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-decreases-holdings-in-valvoline-inc-nysevvv/">Zurcher Kantonalbank Zurich Cantonalbank Decreases Holdings in Valvoline Inc. (NYSE:VVV)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-sells-540-shares-of-amn-healthcare-services-inc-nyseamn/">Zurcher Kantonalbank Zurich Cantonalbank Sells 540 Shares of AMN Healthcare Services, Inc. (NYSE:AMN)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-has-630000-holdings-in-synovus-financial-corp-nysesnv/">Zurcher Kantonalbank Zurich Cantonalbank Has $630,000 Holdings in Synovus Financial Corp. (NYSE:SNV)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-lowers-position-in-amn-healthcare-services-inc-nyseamn/">Zurcher Kantonalbank Zurich Cantonalbank Lowers Position in AMN Healthcare Services, Inc. (NYSE:AMN)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/donaldson-company-inc-nysedci-shares-sold-by-zurcher-kantonalbank-zurich-cantonalbank/">Donaldson Company, Inc. (NYSE:DCI) Shares Sold by Zurcher Kantonalbank Zurich Cantonalbank</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/halozyme-therapeutics-inc-nasdaqhalo-shares-sold-by-zurcher-kantonalbank-zurich-cantonalbank/">Halozyme Therapeutics, Inc. (NASDAQ:HALO) Shares Sold by Zurcher Kantonalbank Zurich Cantonalbank</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/wells-fargo-company-mn-boosts-stock-position-in-ishares-morningstar-small-value-etf-nysearcaiscv/">Wells Fargo &#038; Company MN Boosts Stock Position in iShares Morningstar Small Value ETF (NYSEARCA:ISCV)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-sells-2864-shares-of-jefferies-financial-group-inc-nysejef/">Zurcher Kantonalbank Zurich Cantonalbank Sells 2,864 Shares of Jefferies Financial Group Inc. (NYSE:JEF)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-has-657000-stock-position-in-interactive-brokers-group-inc-nasdaqibkr/">Zurcher Kantonalbank Zurich Cantonalbank Has $657,000 Stock Position in Interactive Brokers Group, Inc. (NASDAQ:IBKR)</a></li>
<li class="recent-posts"><a href="https://www.etfdailynews.com/2022/12/09/zurcher-kantonalbank-zurich-cantonalbank-sells-859-shares-of-the-descartes-systems-group-inc-nasdaqdsgx/">Zurcher Kantonalbank Zurich Cantonalbank Sells 859 Shares of The Descartes Systems Group Inc. (NASDAQ:DSGX)</a></li>
 </ul>
</div>
</div>
</div>

</aside>
<div style="clear: both;"></div>
</div> 
<footer class="full-width">
<div class="width-limiter flex-container">
<div id="footer-info" class="add-padding flex-nav">
</div>
<span id="copyright" class="add-padding flex-copyright">
&copy; 2018-2022 <a href="https://www.etfdailynews.com">ETF Daily News</a>
</span>
</div>

<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/standalone/viewcount.ashx?ArticleHistoryID=99229719&PostDate=2022-12-9&type=f&id=13421743&domain=www.etfdailynews.com&referrer=' + encodeURIComponent(document.referrer) + '" alt="" width="1" height="1" style="float:left;" />');</script>

</footer>
</div>

<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1" alt=""></noscript>


<script type="text/javascript">
var sc_project=12682890; 
var sc_invisible=1; 
var sc_security="f2745ebe"; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/12682890/0/f2745ebe/1/" height="1" width="1"  alt=""></noscript>

</body>
</html>
